Project

General

Profile

action #44381

[sle][migration][SLE15SP1] test fails in installation_overview - seems loop happen during installation on 390x

Added by coolgw over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-11-27
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

The conflict happen during installation seems can not resolve, maybe an product issue, need further investigate.

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-TEST-s390x-0001offline_sles12sp3_media_sdk+tcm+phub_def_full_addonurl@s390x-kvm-sle15 fails in
installation_overview

Reproducible

Fails since (at least) Build 100.4 (current job)

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by coolgw over 3 years ago

  • Subject changed from [sle][migration][SLE15SP1] test fails in installation_overview to [sle][migration][SLE15SP1] test fails in installation_overview - seems loop happen during installation on 390x

#2 Updated by sunyan over 3 years ago

  • Priority changed from Normal to High

#3 Updated by coolgw over 3 years ago

apacq1 env is ready, but after clone job for reproduce this issue, found block by ftp issue, please check following failed link
/usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa-apac1.suse.de 2275735 WORKER_CLASS=svirt-enif ADDONURL="base,sdk,tcm" SCC_ADDONS="sdk,tcm"
http://openqa-apac1.suse.de/tests/2489#

#4 Updated by coolgw over 3 years ago

  • Status changed from New to Blocked

block by ftp issue #44672

#5 Updated by coolgw over 3 years ago

currently #44672 is unblock on 107.5, means ftp link on 107.5 is ready.
So i try to clone it on 107.5 test case, but currently i found another #44666 block this case again, so i need take #44666 firstly.
So this case still on blocking state.

#6 Updated by coolgw over 3 years ago

#44666 disappear after rerun, after quick check the latest result, currently block on addonurl part, seems can not find ADDONURL_SDK ftp://openqa.suse.de/SLE-15-SP1-SDK-POOL-s390x-Build107.5-Media1/
https://openqa.suse.de/tests/2300705#

So i prepare using setting without SDK to run again to avoid this issue.

#7 Updated by coolgw over 3 years ago

run following clone command seems reproduce this issue now.
/usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa-apac1.suse.de 2300705 WORKER_CLASS=svirt-enif ADDONURL_PHUB="" ADDONURL_SDK="" ADDONURL_TCM="" SCC_ADDONS="sdk,tcm" WORKAROUND_MODULES=desktop
http://openqa-apac1.suse.de/tests/2524#

But only add WORKAROUND_MODULES=desktop can trigger this issue, and this setting will only add desktop application during addon_products_sle phase, this is not the correct scenario, should we still need fix this issue?

#8 Updated by coolgw over 3 years ago

  • Status changed from Blocked to In Progress

#9 Updated by coolgw over 3 years ago

Add correct url this conflict not exist anymore, see following test case result.
/usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa-apac1.suse.de 2300705 WORKER_CLASS=svirt-enif ADDONURL=base,sdk ADDONURL_BASE=ftp://openqa.suse.de/SLE-15-SP1-Module-Basesystem-POOL-s390x-Build107.5-Media1 ADDONURL_SDK=ftp://openqa.suse.de/SLE-15-SP1-Module-Development-Tools-POOL-s390x-Build107.5-Media1/ ADDONURL_TCM=ftp://openqa.suse.de/SLE-15-SP1-Module-Web-Scripting-POOL-s390x-Build107.5-Media1/ ADDONURL_DESKTOP=ftp://openqa.suse.de/SLE-15-SP1-Module-Desktop-Applications-POOL-s390x-Build107.5-Media1/ ADDONURL_LEGACY=ftp://openqa.suse.de/SLE-15-SP1-Module-Legacy-POOL-s390x-Build107.5-Media1/ ADDONURL_SERVERAPP=ftp://openqa.suse.de/SLE-15-SP1-Module-Server-Applications-POOL-s390x-Build107.5-Media1/ ADDONURL_SLES=ftp://openqa.suse.de/SLE-15-SP1-Product-SLES-POOL-s390x-Build107.5-Media1/ SCC_ADDONS=sdk

Created job #2529: sle-15-SP1-Installer-DVD-s390x-Build107.5-offline_sles12sp3_media_sdk+tcm+phub_def_full_s390x@s390x-kvm-sle12 -> http://openqa-apac1.suse.de/t2529

#10 Updated by coolgw over 3 years ago

  • Status changed from In Progress to Resolved

#11 Updated by leli over 3 years ago

  • Status changed from Resolved to In Progress

It seems happened again, https://openqa.suse.de/tests/2393856 .

#12 Updated by coolgw over 3 years ago

Try using another parameter BREAK_DEPS=1
/usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa-apac1.suse.de 2447664 --skip-download WORKAROUND_DEPS="" BREAK_DEPS=1 WORKER_CLASS=svirt-enif
Created job #3306: sle-15-SP1-Installer-DVD-POST-s390x-Build158.4-offline_sles12sp3_scc_sdk+tcm+Phub_all_full@s390x-kvm-sle12 -> http://openqa-apac1.suse.de/t3306

block on install_service, ftp server exist some issue?
http://openqa-apac1.suse.de/tests/3308#step/install_service/8

#13 Updated by coolgw over 3 years ago

/usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 2467343 --skip-download WORKAROUND_DEPS="" BREAK_DEPS=1
If you change setting as BREAK_DEPS=1, the loop seem not exist!! You can check following result:
https://openqa.suse.de/tests/2470567#step/installation_overview/76

#14 Updated by coolgw over 3 years ago

update phub cases to BREAK_DEPS=1

#15 Updated by coolgw over 3 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF