Project

General

Profile

action #42029

[sle][functional][u] - test fails in reconnect_s390 - race condition when switching to svirt console and password prompt

Added by mloviska about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 20
Start date:
2018-10-05
Due date:
2018-11-06
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP4-Server-DVD-s390x-create_hdd_textmode@zkvm fails in
reconnect_s390

To avoid this race condition we should wait for the password prompt before any console modification is done as expected over here:
https://openqa.suse.de/tests/2119365#step/reconnect_s390/6

Reproducible

Fails since (at least) Build 0410 (current job)

Expected result

Last good: 0406 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Blocked by openQA Project - action #41504: [s390x][functional][u] test fails in svirt_upload_assets - adjust backend to use keys instead of passwords - "evil sleep"Resolved2018-09-242018-10-23

History

#1 Updated by okurz about 3 years ago

  • Blocked by action #41504: [s390x][functional][u] test fails in svirt_upload_assets - adjust backend to use keys instead of passwords - "evil sleep" added

#2 Updated by okurz about 3 years ago

  • Due date set to 2018-11-06
  • Status changed from New to Blocked
  • Assignee set to okurz
  • Target version set to Milestone 20

#3 Updated by okurz about 3 years ago

  • Status changed from Blocked to Resolved

blocker resolved, https://openqa.suse.de/tests/2234456 and past 10 jobs in same scenario are fine as well. I assume we are done here.

Also available in: Atom PDF