action #41543

parallel_failed jobs miss t_finished

Added by coolo over 1 year ago. Updated over 1 year ago.

Status:ResolvedStart date:25/09/2018
Priority:NormalDue date:
Assignee:mkittler% Done:

0%

Category:Feature requests
Target version:Done
Difficulty:easy
Duration:

Description

A job that is not active should get a t_finished. This is easier in all kind of sortings.

openqa=> select distinct state,result from jobs where result!='none' and t_finished is null;
     state      |       result       
----------------+--------------------
 user_cancelled | parallel_restarted
 skipped        | parallel_restarted
 user_cancelled | parallel_failed

There might be multiple places where we set the result without a t_finished


Related issues

Related to openQA Project - action #41483: [tools] medium that should belong to job group was delete... Resolved 24/09/2018

History

#1 Updated by coolo over 1 year ago

  • Related to action #41483: [tools] medium that should belong to job group was deleted after just 2 minutes making our SLE15 tests in build 47.1 useless ... and more added

#2 Updated by mkittler over 1 year ago

  • Status changed from New to In Progress
  • Assignee set to mkittler

The problem is that user_cancelled and skipped are no valid job states and hence also no final job states. So those jobs never got a final state assigned and hence also no t_finished. (user_cancelled and skipped are actually results.)

So assigning those results as a state needs to be fixed.

There might be multiple places where we set the result without a t_finished

That is not a problem as long as a valid final state is assigned at some point.

Maybe it makes also sense to improve the validation.

#4 Updated by mkittler over 1 year ago

I don't know where the jobs with status user_cancelled come from. But those jobs on OSD are quite old (1) and likely the bug which caused these has already been fixed. I tested the database migration to fix the wrong states locally with OSD data. The query from the ticket description yields no results after that and t_finished is not altered for jobs where it is already set.

(1)

select t_created from jobs where state = 'user_cancelled' order by t_created desc;
      t_created      
---------------------
 2016-09-19 21:20:03
 2016-09-19 17:32:18
 2016-09-19 17:32:18
 2016-09-15 22:40:12
 2016-09-15 10:00:59

#5 Updated by coolo over 1 year ago

  • Status changed from In Progress to Resolved
  • Target version changed from Current Sprint to Done

merged

Also available in: Atom PDF