action #41144

[functional][u][hyperv] test fails in bootloader_hyperv - The operation cannot be performed while the object is in use.

Added by nicksinger over 1 year ago. Updated over 1 year ago.

Status:ResolvedStart date:17/09/2018
Priority:LowDue date:
Assignee:michalnowak% Done:

0%

Category:Bugs in existing tests
Target version:QA - future
Difficulty:
Duration:

Description

Observation

openQA test in scenario sle-12-SP4-Server-DVD-x86_64-lvm+RAID1@svirt-hyperv-uefi fails in
bootloader_hyperv
The command fails with the message:

Test died: Command failed with unhandled error:
 Start-VM : 'openQA-SUT-2' failed to change state.
 The operation cannot be performed while the object is in use.
 At line:1 char:1
 + Start-VM openQA-SUT-2
 + ~~~~~~~~~~~~~~~~~~~~~
     + CategoryInfo          : ResourceBusy: (:) [Start-VM], VirtualizationExce 
    ption
     + FullyQualifiedErrorId : ObjectInUse,Microsoft.HyperV.PowerShell.Commands 
    .StartVM

. at /var/lib/openqa/cache/tests/sle/tests/installation/bootloader_hyperv.pm line 49.

It happens on many (all?) hyperV jobs inside functional:
https://openqa.suse.de/tests/2061029#step/bootloader_hyperv/70
https://openqa.suse.de/tests/2061047#step/bootloader_hyperv/40
https://openqa.suse.de/tests/2061030#step/bootloader_hyperv/40

Reproducible

Fails since most recent Build 0391

History

#1 Updated by nicksinger over 1 year ago

  • Description updated (diff)

#2 Updated by okurz over 1 year ago

  • Subject changed from [functional][hyperV][fast] test fails in bootloader_hyperv - The operation cannot be performed while the object is in use. to [functional][u][hyperv] test fails in bootloader_hyperv - The operation cannot be performed while the object is in use.
  • Due date changed from 25/09/2018 to 09/10/2018
  • Target version set to Milestone 19

If you don't mind, I remove "[fast]" again – and add "[u]" – as "hyperv" so far is not what our stakeholders look at as critical. Still, of course we should look into this soon as it is a hot regression :)

#3 Updated by okurz over 1 year ago

  • Due date deleted (09/10/2018)
  • Priority changed from Normal to Low
  • Target version changed from Milestone 19 to future

Hm, was not "all" in build 0391 and only one in 0393, https://openqa.suse.de/tests/2068724#, the others are fine

#4 Updated by nicksinger over 1 year ago

Happened again: https://openqa.suse.de/tests/2084550#step/bootloader_hyperv/40
I'd also say this is not a product issue but more of an environment/backend issue.

#5 Updated by michalnowak over 1 year ago

  • Status changed from Workable to Feedback
  • Assignee set to michalnowak

#6 Updated by michalnowak over 1 year ago

  • Status changed from Feedback to Resolved

PR merged.

Also available in: Atom PDF