Project

General

Profile

action #40547

[qam][opensuse] test fails in updates_packagekit_kde - job timeout

Added by pcervinka about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2018-09-04
Due date:
% Done:

90%

Estimated time:
Difficulty:
medium

Description

Observation

openQA test in scenario opensuse-15.0-DVD-Updates-x86_64-kde@64bit-2G fails in
updates_packagekit_kde

Reproducible

Fails since (at least) Build 20180903-4 (current job)

Expected result

Last good: 20180903-3 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by pcervinka about 3 years ago

Tests will timeout in the loop searching for needles:

[2018-09-03T22:47:58.0624 CEST] [debug] no match: 10710.0s
[2018-09-03T22:47:58.0642 CEST] [debug] MATCH(gnome_updates_packagekit_updates_none--20180328:0.00)
[2018-09-03T22:47:58.0644 CEST] [debug] MATCH(updates_kde-updates_none-20160526:0.00)
[2018-09-03T22:47:58.0653 CEST] [debug] MATCH(updates_none-20160523:0.00)
[2018-09-03T22:47:58.0662 CEST] [debug] MATCH(updates_none-20160827:0.00)
[2018-09-03T22:47:58.0672 CEST] [debug] MATCH(updates_none-20180311:0.00)
[2018-09-03T22:47:58.0673 CEST] [debug] MATCH(updates_packagekit_kde-no-updates_available-20180217:0.00)
[2018-09-03T22:47:58.0674 CEST] [debug] MATCH(updates_packagekit_kde-no-updates_available-20180218:0.00)
[2018-09-03T22:47:58.0676 CEST] [debug] MATCH(updates_packagekit_kde-no-updates_available-20180310:0.00)
[2018-09-03T22:47:58.0678 CEST] [debug] MATCH(updates_packagekit_kde-updates_none-20180125:0.00)
[2018-09-03T22:47:58.0681 CEST] [debug] MATCH(updates_packagekit_kde-updates_none-20180322:0.00)
[2018-09-03T22:47:58.0682 CEST] [debug] MATCH(updates_packagekit_kde-no-updates_available-20180828:0.00)
[2018-09-03T22:47:58.0686 CEST] [debug] MATCH(updates_available-20160527:0.00)
[2018-09-03T22:47:58.0690 CEST] [debug] MATCH(updates_kde-updates_available-20160526:0.00)
[2018-09-03T22:47:58.0693 CEST] [debug] MATCH(updates_kde-updates_available-20161105:0.00)
[2018-09-03T22:47:58.0696 CEST] [debug] MATCH(updates_kde-updates_available-20171108:0.00)
[2018-09-03T22:47:58.0700 CEST] [debug] MATCH(updates_kde-updates_available-20180104:0.00)
[2018-09-03T22:47:58.0703 CEST] [debug] MATCH(updates_kde-updates_available-20180121:0.00)
[2018-09-03T22:47:58.0706 CEST] [debug] MATCH(updates_kde-updates_available-20180124:0.00)
[2018-09-03T22:47:58.0707 CEST] [debug] no match: 10708.8s
[2018-09-03T22:47:59.0636 CEST] [debug] MATCH(gnome_updates_packagekit_updates_none--20180328:0.00)
[2018-09-03T22:47:59.0639 CEST] [debug] MATCH(updates_kde-updates_none-20160526:0.00)
[2018-09-03T22:47:59.0648 CEST] [debug] MATCH(updates_none-20160523:0.00)
[2018-09-03T22:47:59.0657 CEST] [debug] MATCH(updates_none-20160827:0.00)
[2018-09-03T22:47:59.0666 CEST] [debug] MATCH(updates_none-20180311:0.00)
[2018-09-03T22:47:59.0668 CEST] [debug] MATCH(updates_packagekit_kde-no-updates_available-20180217:0.00)
[2018-09-03T22:47:59.0671 CEST] [debug] MATCH(updates_packagekit_kde-no-updates_available-20180218:0.00)
[2018-09-03T22:47:59.0673 CEST] [debug] MATCH(updates_packagekit_kde-no-updates_available-20180310:0.00)
[2018-09-03T22:47:59.0678 CEST] [debug] MATCH(updates_packagekit_kde-updates_none-20180125:0.00)
[2018-09-03T22:47:59.0682 CEST] [debug] MATCH(updates_packagekit_kde-updates_none-20180322:0.00)
[2018-09-03T22:47:59.0684 CEST] [debug] MATCH(updates_packagekit_kde-no-updates_available-20180828:0.00)
[2018-09-03T22:47:59.0692 CEST] [debug] MATCH(updates_available-20160527:0.00)
[2018-09-03T22:47:59.0697 CEST] [debug] MATCH(updates_kde-updates_available-20160526:0.00)
[2018-09-03T22:47:59.0700 CEST] [debug] MATCH(updates_kde-updates_available-20161105:0.00)
[2018-09-03T22:47:59.0703 CEST] [debug] MATCH(updates_kde-updates_available-20171108:0.00)
[2018-09-03T22:47:59.0707 CEST] [debug] MATCH(updates_kde-updates_available-20180104:0.00)
[2018-09-03T22:47:59.0710 CEST] [debug] MATCH(updates_kde-updates_available-20180121:0.00)
[2018-09-03T22:47:59.0713 CEST] [debug] MATCH(updates_kde-updates_available-20180124:0.00)
[2018-09-03T22:47:59.0713 CEST] [debug] no match: 10707.8s
[2018-09-03T22:48:00.0637 CEST] [debug] MATCH(gnome_updates_packagekit_updates_none--20180328:0.00)
[2018-09-03T22:48:00.0640 CEST] [debug] MATCH(updates_kde-updates_none-20160526:0.00)
[2018-09-03T22:48:00.0649 CEST] [debug] MATCH(updates_none-20160523:0.00)
[2018-09-03T22:48:00.0658 CEST] [debug] MATCH(updates_none-20160827:0.00)
[2018-09-03T22:48:00.0671 CEST] [debug] MATCH(updates_none-20180311:0.00)
[2018-09-03T22:48:00.0672 CEST] [debug] MATCH(updates_packagekit_kde-no-updates_available-20180217:0.00)
[2018-09-03T22:48:00.0674 CEST] [debug] MATCH(updates_packagekit_kde-no-updates_available-20180218:0.00)
[2018-09-03T22:48:00.0675 CEST] [debug] MATCH(updates_packagekit_kde-no-updates_available-20180310:0.00)
[2018-09-03T22:48:00.0678 CEST] [debug] MATCH(updates_packagekit_kde-updates_none-20180125:0.00)
[2018-09-03T22:48:00.0680 CEST] [debug] MATCH(updates_packagekit_kde-updates_none-20180322:0.00)
[2018-09-03T22:48:00.0682 CEST] [debug] MATCH(updates_packagekit_kde-no-updates_available-20180828:0.00)
[2018-09-03T22:48:00.0686 CEST] [debug] MATCH(updates_available-20160527:0.00)

Most probably not matched needle https://openqa.opensuse.org/tests/747054#step/updates_packagekit_kde/14.
Needle contains number of notifications which can be different during the time. Video
with failed test contains 4 notifications.

Needle was update, test restarted, waiting for result.

#2 Updated by pcervinka about 3 years ago

Here is the code which will keep openQA in the loop till global timeout, in case no needle is matched:

        # First update package manager, then packages, then bsc#992773 (2x)
        while (1) {
            assert_and_click_until_screen_change('updates_click-install');

            # Wait until installation starts, intended to time out
            wait_still_screen(stilltime => 4, timeout => 5);

            # Wait until installation is done
            assert_screen \@updates_installed_tags, 3600;

            # Make sure the applet has fetched the current status from the backend
            # and has finished redrawing. In case the update status changed after
            # the assert_screen, record a soft failure
            wait_still_screen;
            if (match_has_tag('updates_none')) {
                if (check_screen 'updates_none', 30) {
                    last;
                }
                else {
                    record_soft_failure 'boo#992773';
                }
            }
            elsif (match_has_tag('updates_available')) {
                # look again
                if (check_screen 'updates_none', 0) {
                    record_soft_failure 'boo#1041112';
                    last;
                }
            }

#4 Updated by pcervinka about 3 years ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 90

PR merged let's see couple of future runs on ooo.

#5 Updated by pcervinka about 3 years ago

  • Target version changed from Current Sprint to 445

#6 Updated by pcervinka about 3 years ago

  • Status changed from Feedback to Resolved

#7 Updated by sebchlad about 3 years ago

  • Target version changed from 445 to Done

Also available in: Atom PDF