Project

General

Profile

action #38969

[tw][desktop] Migrate regression-gnome cases of SLE to Tumbleweed named desktopapps-gnome

Added by yuanren10 about 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Target version:
-
Start date:
2018-07-31
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

We should:

  1. Update the cases
  2. Update main.pm(both sle and tw) and main_common.pm
  3. Create testsuite in o.o.o

testsuite of regression-gnome:

BOOTFROM=c
HDD_1=openSUSE-%VERSION%-%BUILD%-%ARCH%_for_regression.qcow2
REGRESSION=gnome
START_AFTER_TEST=regression-installation

Including

  • nautilus_cut_file
  • nautilus_permission
  • nautilus_open_ftp
  • change_password
  • login_test
  • gnome_classic_switch
  • gnome_default_applications
  • gnome_window_switcher
  • application_starts_on_login

Related issues

Related to openQA Tests - action #43010: [tw][desktop] Add regression-gnome cases for NOAUTOLOGIN checkingResolved2018-10-29

History

#1 Updated by yuanren10 about 2 years ago

  • Subject changed from [tw][desktop] Migrate regression-gnome cases of SLE to Tumbleweed to [tw][desktop] Migrate regression-gnome cases of SLE to Tumbleweed named desktopapps-gnome

testsuite of desktopapps-gnome:

BOOTFROM=c
HDD_1=openSUSE-%VERSION%-%BUILD%-%ARCH%_for_regression.qcow2
REGRESSION=gnome
START_AFTER_TEST=create_hdd_gnome

#2 Updated by yuanren10 about 2 years ago

Please reference PR#5494

Waiting for PR#5492 to be merged.

#3 Updated by okurz about 2 years ago

  • Category set to New test

#4 Updated by yfjiang almost 2 years ago

  • Assignee changed from yuanren10 to zgao

#5 Updated by zgao almost 2 years ago

okurz

Could you please update the testsuite as following?

BOOT_HDD_IMAGE=1
DESKTOP=gnome
HDD_1=%DISTRI%-%VERSION%-%ARCH%-%BUILD%-gnome@%MACHINE%.qcow2
REGRESSION=gnome
START_AFTER_TEST=create_hdd_gnome
UEFI_PFLASH_VARS=openSUSE-%VERSION%-%BUILD%-%ARCH%_for_regression-uefi-vars.qcow2

I am updating since now regression-gnome is not using the correct qcow2 from create_hdd_gnome, which we can tell from o.o.o run cases https://openqa.opensuse.org/tests/781368
Also, my verification run is here

Thank you.

#6 Updated by zgao almost 2 years ago

We should update the testsuite as following

BOOT_HDD_IMAGE=1
DESKTOP=gnome
HDD_1=%DISTRI%-%VERSION%-%ARCH%-%BUILD%-gnome@%MACHINE%.qcow2
REGRESSION=gnome
START_AFTER_TEST=create_hdd_gnome

The qcow we use is changed from regression-installation to create_hdd_gnome.

We don't need the parameter UEFI_PFLASH_VARS as it is added according to https://progress.opensuse.org/issues/39695 and this commit, which seems not relevant to tumbleweed.

In addition, regression-installation can be remove from o3 as it is not needed by any other jobs currently.

For you information,
regression-gnome on o3 https://openqa.opensuse.org/tests/781368
my verification run

#7 Updated by zgao almost 2 years ago

  • Related to action #43010: [tw][desktop] Add regression-gnome cases for NOAUTOLOGIN checking added

Also available in: Atom PDF