Project

General

Profile

action #38861

[opensuse] test fails in first_boot

Added by osukup almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-07-26
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.0-DVD-Updates-x86_64-kde@64bit-2G fails in
first_boot

Reproducible

Fails since (at least) Build 20180725-4

Expected result

Last good: 20180725-3 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Has duplicate openQA Tests - action #38864: [functional][opensuse][u] errors--compilation from first_boot.pmRejected2018-07-26

History

#1 Updated by okurz almost 4 years ago

  • Status changed from New to Feedback
  • Assignee set to okurz

#2 Updated by okurz almost 4 years ago

  • Has duplicate action #38864: [functional][opensuse][u] errors--compilation from first_boot.pm added

#3 Updated by zluo almost 4 years ago

The problem was

use version_utils 'sle_version_at_least';

line 60 of first_boot.pm:

if (!is_sle('<=15') && !is_leap('<=15.0') && check_var('ARCH', 'aarch64') && check_var('DESKTOP', 'gnome')) {
..

--
Please see

http://e13.suse.de/tests/7118

I changed
use version_utils 'sle_version_at_least'; to use version_utils ;

#4 Updated by okurz almost 4 years ago

  • Status changed from Feedback to Resolved

I already mentioned the commit in master that fixed it.

No further failures seen on production.

Also available in: Atom PDF