Project

General

Profile

action #38591

[s390x][kvm] "DIE 'current_console' is not set" in boot_to_desktop

Added by yosun about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-07-19
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

All xfstests run in s390x incomplete and logs shows:
error: failed to get domain 'openQA-SUT-1'
https://openqa.suse.de/tests/1842800/file/autoinst-log.txt
https://openqa.suse.de/tests/1842800

The chained task works ok: create_hdd_minimal_base+sdk_withhome

I use the same setting as SLE15, but change machine to use "s390x-kvm-sle12". I don't get where the problem is.

History

#1 Updated by okurz about 3 years ago

  • Subject changed from Failed to get domain 'openQA-SUT-1' to [s390x][kvm] "DIE 'current_console' is not set" in boot_to_desktop

You can take a look further up in https://openqa.suse.de/tests/1842800/file/autoinst-log.txt:

DIE 'current_console' is not set at /usr/lib/os-autoinst/backend/baseclass.pm line 732.
    backend::baseclass::wait_serial('backend::svirt=HASH(0x7784d98)', 'HASH(0x68a98d8)') called at /usr/lib/os-autoinst/backend/baseclass.pm line 75

that is the actual error

#2 Updated by yosun about 3 years ago

Well, I still don't know how to fix it in baseclass.pm
Is this probably related with bsc#1103030? Since domain issue may related with network issue. But it also fails in Build0325, which contain the fix. Weird.
Could someone help to take a look of it please?

#3 Updated by okurz about 3 years ago

  • Project changed from openQA Project to openQA Tests
  • Category set to Bugs in existing tests

I do not know the exact solution but I assume it would help if you compare the test schedule to working examples, e.g. https://openqa.suse.de/tests/1899848 in the test suite "extra_tests_in_textmode". IMHO you need schedule bootloader_zkvm and boot_to_desktop as part of your schedule.

#4 Updated by yosun about 3 years ago

Thank you, I agree with you. I think to load bootloader_zkvm.pm before booting will solve this problem.

#5 Updated by yosun about 3 years ago

  • Status changed from New to Resolved

I found the problem, xfstests load "boot/boot_to_desktop", I should change it to "boot_hdd_image".

Also available in: Atom PDF