Project

General

Profile

action #38291

[functional][u][sporadic][aarch64] - Wrong timeout is set in 'disable_grub_timeout', that leads to fail in 'grub_test' module

Added by oorlov about 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2018-07-06
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

grub_test fails because it is waiting for Grub menu, but the further steps already loaded.

It is happened because in the disable_grub_timeout, timeout is set to '0', but should be set to '-1'.

openQA test in scenario sle-12-SP4-Server-DVD-aarch64-textmode+proxy_SCC@aarch64 fails in
grub_test

Suggestion

In disable_grub_timeout module, check that correct timeout is set, as currently it is not checked at all. The test just enters '-1' and assumes that everything is going ok.

Reproducible

Fails since (at least) Build 0245

Expected result

Last good: 0243 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by oorlov about 2 years ago

  • Description updated (diff)

#2 Updated by okurz about 2 years ago

  • Target version set to future

#3 Updated by okurz over 1 year ago

  • Status changed from New to Rejected
  • Assignee set to okurz

Also available in: Atom PDF