Project

General

Profile

action #38066

[qam] [sle] [functional] test fails in application_starts_on_login - failure after check_screen change

Added by pcervinka over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-07-02
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Desktop-DVD-Updates-x86_64-qam-regression-gnome@64bit fails in
application_starts_on_login

Reproducible

Fails since (at least) Build 20180629-2

Expected result

Last good: 20180629-1 (or more recent)

Further details

Always latest result in this scenario: latest

Failures started after https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5131
Use explicit timeout on every check_screen call to make time investment obvious

  • if (check_screen("dconf-caution")) {
  • assert_and_click "will-be-careful";
  • }

  • assert_and_click 'will-be-careful' if check_screen 'dconf-caution', 0;

Also available in: Atom PDF