Project

General

Profile

action #37713

[functional][u] test fails in vlc - sometimes fails to close vlc

Added by mlin7442 about 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA tests - Milestone 20
Start date:
2018-06-23
Due date:
2018-10-23
% Done:

0%

Estimated time:
Difficulty:
Duration: 87

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-gnome@64bit fails in
vlc

sometimes fails to close vlc

Reproducible

Fails since (at least) Build 20180622

Expected result

Last good: 20180620 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #42773: [functional][u] extend VLC test to check correct renderingNew2018-10-22

Related to openQA Tests - action #42671: [opensuse][functional][u] test fails in vlc - needle vlc-done-playing does not matchResolved2018-10-18

History

#1 Updated by okurz about 2 years ago

  • Subject changed from test fails in vlc - sometimes fails to close vlc to [functional][u] test fails in vlc - sometimes fails to close vlc
  • Target version set to future

#2 Updated by okurz almost 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: gnome
https://openqa.opensuse.org/tests/705703

#3 Updated by okurz almost 2 years ago

  • Target version changed from future to Milestone 18

#4 Updated by okurz almost 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: system_performance
https://openqa.opensuse.org/tests/745455

#5 Updated by okurz almost 2 years ago

  • Due date set to 2018-10-23
  • Target version changed from Milestone 18 to Milestone 20

#6 Updated by zluo almost 2 years ago

  • Status changed from New to In Progress
  • Assignee set to zluo

#7 Updated by zluo almost 2 years ago

# sometimes send_key for closing windows not working
send_key_until_needlematch 'generic-desktop', "ctrl-q", 5, 5;

We had this issue before, so this happened again, but sometimes or sporadic.

#8 Updated by zluo almost 2 years ago

changed to send_key_until_needlematch 'generic-desktop', "ctrl-q", 10, 5;

http://e13.suse.de/tests/8994#step/vlc/50 still shows sporadic issue

#9 Updated by zluo almost 2 years ago

http://e13.suse.de/tests/9096#step/vlc/25 shows old needle match 96%, should be deleted.

#10 Updated by zluo almost 2 years ago

found sporadic issue for needle match "url_check":

http://e13.suse.de/tests/9123#step/vlc/25

increase timeout to 60 sec for try:
assert_screen "url_check", 60;

#11 Updated by zluo almost 2 years ago

http://e13.suse.de/tests/9203#step/vlc/25

97% match for vlc-url_check-20181005, add a new needle now.

#12 Updated by okurz almost 2 years ago

Please make sure we have only needles which do not cover the blinking cursor but keep in mind that this ticket is about "closing vlc"

#13 Updated by zluo almost 2 years ago

use assert_and_click "close_app"; for now, to replace:

# sometimes send_key for closing windows not working
# send_key_until_needlematch 'generic-desktop', "ctrl-q", 10, 10;

http://e13.suse.de/tests/9263#step/vlc/26

#16 Updated by zluo over 1 year ago

  • Status changed from In Progress to Feedback

waiting for merge my PR.

#17 Updated by okurz over 1 year ago

PR merged, please monitor according jobs on production for at least both openSUSE Tumbleweed and Leap

#18 Updated by okurz over 1 year ago

  • Assignee changed from zluo to okurz

Seems like you missed my suggestion in https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5897#issuecomment-429309062

Many tests failed because of - maybe obvious - missing needles. Created new needles with lower match level and smaller areas to be more resiliant. I am also monitoring openSUSE Tumbleweed on different arches, Leap, as well as the Maintenance jobs I could find failing in vlc.

#19 Updated by okurz over 1 year ago

  • Status changed from Feedback to Resolved

Could not find anymore failed test steps in VLC on openqa.opensuse.org checking openSUSE Tumbleweed, ports, Leap, maintenance tests except for one failure in openSUSE Tumbleweed with a correctly referenced product bug regarding VLC. I guess we are done here now.

#20 Updated by zluo over 1 year ago

  • Status changed from Resolved to Workable
  • Assignee changed from okurz to zluo

https://openqa.opensuse.org/tests/775034#step/vlc/27 shows that needle got found for assert_and_click but vlc still cannot get closed.

Think about to repeat this action...

#21 Updated by zluo over 1 year ago

I think we have this issue again: https://bugzilla.opensuse.org/show_bug.cgi?id=1102838

https://openqa.opensuse.org/tests/775034#step/vlc/26 shows needle match for vlc_playing, but I don't see screen for this playing before like:
https://openqa.opensuse.org/tests/769052#step/vlc/27

So the current vlc-done-playing needle is always matching even when vlc cannot play the video.
First change is to create a new needle from page: https://openqa.opensuse.org/tests/769052#step/vlc/28

#22 Updated by okurz over 1 year ago

https://openqa.opensuse.org/tests/769052/file/video.ogv#t=252.62,252.67 shows what happens in the case of passing tests: The URL to the video is typed, the play button is pressed, the screen referenced before shows up what looks like the video is done but it is not, it never started. It only starts afterwards.

#23 Updated by zluo over 1 year ago

okurz I found also the order of screens is wrong, 00:21 shows up before 00:20 :)

https://openqa.opensuse.org/tests/769052/#step/vlc/27

#24 Updated by zluo over 1 year ago

  • Status changed from Workable to In Progress

#25 Updated by zluo over 1 year ago

delete existing needle: vlc-done-playing and create a new one at place where video is playing.

add record_soft_failure for 'boo#1102838 - VLC fails to play video' :
http://e13.suse.de/tests/9640#step/vlc/25

and of course in case that video could be played:
http://e13.suse.de/tests/9652#step/vlc/25

#28 Updated by okurz over 1 year ago

As discussed with zluo we assume that the bug https://bugzilla.suse.com/show_bug.cgi?id=1102838 might actually be invalid as the needles with the tag "vlc-done-playing" are not giving VLC enough time to check if the video actually started. zluo tried to ensure this with needles covering the background of the actually rendered video which could turn out to be not perfectly robust but we can still create new needles when the video actually stopped playing. However the new needle(s) should cover the pause button which turned into a play button. https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5997 reverts the last code change. I delete the "info" needle which would match prematurely and will monitor according jobs on o3. I also provided a comment in the bug that it might be invalid.

#29 Updated by zluo over 1 year ago

  • Status changed from In Progress to Resolved

https://openqa.opensuse.org/tests/778784#step/vlc/26

shows new needle checking at right place now.

#30 Updated by zluo over 1 year ago

https://openqa.opensuse.org/tests/779198#step/vlc/24 shows correct needle match as well for Leap.

#31 Updated by okurz over 1 year ago

  • Related to action #42773: [functional][u] extend VLC test to check correct rendering added

#32 Updated by okurz over 1 year ago

  • Related to action #42671: [opensuse][functional][u] test fails in vlc - needle vlc-done-playing does not match added

Also available in: Atom PDF