Project

General

Profile

action #36397

[sle][functional][u] zypper_info failed in SLED12SP4

Added by qkzhu over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 19
Start date:
2018-05-22
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP4-Desktop-DVD-x86_64-allpatterns@64bit fails in
zypper_info

Only the source repo of SLES12SP4 was defined in this case
line 54: elsif (sle_version_at_least('12-SP4') and get_var('REPO_SLES_SOURCE')) {

For SLED it was defined as
line 68: $cmd = "ar --type plaindir cd:///?devices=/dev/sr1 repo-source";
which caused the failure.

History

#1 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: cryptlvm
https://openqa.suse.de/tests/1744303

#2 Updated by okurz over 3 years ago

  • Subject changed from [sle][functional] zypper_info failed in SLED12SP4 to [sle][functional][u] zypper_info failed in SLED12SP4
  • Target version set to Milestone 19

#3 Updated by okurz over 3 years ago

  • Target version changed from Milestone 19 to Milestone 19

#4 Updated by zcjia over 3 years ago

The test "zypper_info" is successful for SLES 12 SP4 but failed for SLED 12 SP4, because there are no online source repo (defined by 'REPO_SLES_SOURCE') for SLED.

There is ftp://openqa.suse.de/SLE-12-SP4-SERVER-POOL-x86_64-Build0263-Media2/ available, but there are no SLED 12 SP4 source repo such as ftp://openqa.suse.de/SLE-12-SP4-DESKTOP-POOL-x86_64-Build0236-Media2/ . Is that intentional or an oversight?

#5 Updated by okurz over 3 years ago

I guess "zypper_info" was never working for SLED since it learned to handle source repos about 1 year ago. I recommend to just skip the source package test part for SLED. No need to test this for SLED as well IMHO

#6 Updated by yfjiang over 3 years ago

  • Assignee set to zcjia

It seems only affecting SLED, and removal the case in Desktop sounds reasonable. Assign to Zhaocong for a finishing :-) Thanks!

#7 Updated by zcjia over 3 years ago

  • Status changed from New to In Progress

#8 Updated by zcjia over 3 years ago

  • Status changed from In Progress to Resolved

#9 Updated by okurz over 3 years ago

I am interested, can you share how it was fixed? I assume a pull request but I do not remember from my head. Could you provide the URL to the PR in this case, please?

Also available in: Atom PDF