Project

General

Profile

action #36109

[functional][y] test fails in yast2_dns_server - improve post_fail_hook or investigation process

Added by okurz about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Start date:
2018-05-12
Due date:
2018-06-05
% Done:

0%

Estimated time:
Difficulty:
Duration: 17

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_ncurses@64bit fails in
yast2_dns_server
on what I reported as bsc#1093029. y2logs are parsed as for any other yast2_gui test but there is no further investigation in the post_fail_hook or within the test itself.

Reproducible

Fails since (at least) Build 20171029

Acceptance criteria

  • AC1: Service specific information is provided on failures
  • AC2: Enhanced test code can answer the question what the actual state of the systemd service is

Suggestions

  • Get a bit more named-service specific information in the test either as part of normal test flow or in post_fail_hook, e.g. check systemctl status named in post_fail_hook or collect processes with ps aux as we already do in some other post_fail_hooks
  • Think about applying a generic improvement for all yast2_gui test modules

Further details

Always latest result in this scenario: latest

History

#1 Updated by mloviska about 2 years ago

  • Status changed from New to Workable
  • Assignee set to mloviska

#2 Updated by mloviska about 2 years ago

  • Status changed from Workable to Feedback

#3 Updated by mloviska almost 2 years ago

Post hook did not run over here. Should we wait with closure of this ticket ?
https://openqa.suse.de/tests/1729685#step/yast2_dns_server/37

#4 Updated by okurz almost 2 years ago

  • Status changed from Feedback to Resolved

No need, the job on production showed that your additions did not break the "passed" case ;)

But I would appreciate if you could some information now to the bug report https://bugzilla.opensuse.org/show_bug.cgi?id=1093029 as you know already in more details what happened.

#5 Updated by mloviska almost 2 years ago

The test occasionally does not change the startup behavior, because the keystroke alt-s is lost. Needle "yast2-dns-server-step3" is matched while the screen is just loading default data. Over here is clear that the data have not been loaded properly yet, because yast2 is claiming that the FW port is opened when it is not. So we need to wait while yast2 loads data properly, and afterwards we can start pressing keys.

I cannot see any systemctl start/restart command in the yast2 logs as well.

2018-05-25 12:45:11 <1> susetest(20032) [Ruby] modules/Service.rb:182 Stopping service 'named'
2018-05-25 12:45:11 <1> susetest(20032) [Ruby] yast2/systemctl.rb:32 systemctl show named.service  --property=Id  --property=MainPID  --property=Description  --property=LoadState  --property=ActiveState  --property=SubState  --property=UnitFileState  --property=FragmentPath 
2018-05-25 12:45:12 <1> susetest(20032) [Ruby] yast2/systemctl.rb:32 systemctl stop named.service 
2018-05-25 12:45:12 <1> susetest(20032) [Ruby] yast2/systemctl.rb:32 systemctl show named.service  --property=Id  --property=MainPID  --property=Description  --property=LoadState  --property=ActiveState  --property=SubState  --property=UnitFileState  --property=FragmentPath 
2018-05-25 12:45:12 <1> susetest(20032) [Perl] modules/DnsServer.pm(DnsServer::SetLocalForwarder):909 New local forwarder: resolver
2018-05-25 12:45:12 <2> susetest(20032) [Perl] modules/DnsServer.pm(DnsServer::Write):1563 Local forwarder set to: resolver
2018-05-25 12:45:12 <1> susetest(20032) [Ruby] modules/Service.rb:126 Disabling service 'named'
2018-05-25 12:45:12 <1> susetest(20032) [Ruby] yast2/systemctl.rb:32 systemctl show named.service  --property=Id  --property=MainPID  --property=Description  --property=LoadState  --property=ActiveState  --property=SubState  --property=UnitFileState  --property=FragmentPath 
2018-05-25 12:45:12 <1> susetest(20032) [Ruby] yast2/systemctl.rb:32 systemctl disable named.service 
2018-05-25 12:45:12 <1> susetest(20032) [Ruby] yast2/systemctl.rb:32 systemctl show named.service  --property=Id  --property=MainPID  --property=Description  --property=LoadState  --property=ActiveState  --property=SubState  --property=UnitFileState  --property=FragmentPath 
2018-05-25 12:45:12 <1> susetest(20032) [Perl] modules/DnsServer.pm(DnsServer::Write):1579 NETCONFIG_DNS_FORWARDER has been changed from bind to resolver
2018-05-25 12:45:12 <1> susetest(20032) [Perl] modules/DnsServer.pm(DnsServer::write_local_forwarder):1268 Current dns forwarder: resolver
2018-05-25 12:45:12 <1> susetest(20032) [Perl] modules/DnsServer.pm(DnsServer::write_local_forwarder):1272 Updating forwarders by netconfig
2018-05-25 12:45:12 <1> susetest(20032) [Ruby] firewalld/api.rb:198 Executing firewall-cmd with ["--get-log-denied"]
2018-05-25 12:45:12 <1> susetest(20032) [Ruby] lib/cheetah.rb:158 Executing "firewall-cmd --get-log-denied".
2018-05-25 12:45:13 <1> susetest(20032) [Ruby] lib/cheetah.rb:206 Standard output: off
2018-05-25 12:45:13 <1> susetest(20032) [Ruby] lib/cheetah.rb:178 Status: 0
2018-05-25 12:45:13 <1> susetest(20032) [Ruby] firewalld/api.rb:198 Executing firewall-cmd with ["--get-default-zone"]
2018-05-25 12:45:13 <1> susetest(20032) [Ruby] lib/cheetah.rb:158 Executing "firewall-cmd --get-default-zone".
2018-05-25 12:45:13 <1> susetest(20032) [Ruby] lib/cheetah.rb:206 Standard output: public
2018-05-25 12:45:13 <1> susetest(20032) [Ruby] lib/cheetah.rb:178 Status: 0
2018-05-25 12:45:13 <1> susetest(20032) [Ruby] firewalld/api.rb:198 Executing firewall-cmd with ["--reload"]
2018-05-25 12:45:13 <1> susetest(20032) [Ruby] lib/cheetah.rb:158 Executing "firewall-cmd --reload".
2018-05-25 12:45:15 <1> susetest(20032) [Ruby] lib/cheetah.rb:206 Standard output: success
2018-05-25 12:45:15 <1> susetest(20032) [Ruby] lib/cheetah.rb:178 Status: 0
2018-05-25 12:45:15 <1> susetest(20032) [Ruby] yast2/systemctl.rb:32 systemctl show named.service  --property=Id  --property=MainPID  --property=Description  --property=LoadState  --property=ActiveState  --property=SubState  --property=UnitFileState  --property=FragmentPath 
2018-05-25 12:45:15 <1> susetest(20032) [Ruby] yast2/systemctl.rb:32 systemctl reload named.service 
2018-05-25 12:45:15 <3> susetest(20032) [bash] ShellCommand.cc(shellcommand):78 named.service is not active, cannot reload.
2018-05-25 12:45:15 <1> susetest(20032) [Ruby] yast2/systemctl.rb:32 systemctl show named.service  --property=Id  --property=MainPID  --property=Description  --property=LoadState  --property=ActiveState  --property=SubState  --property=UnitFileState  --property=FragmentPath 
2018-05-25 12:45:15 <1> susetest(20032) [Ruby] clients/dns-server.rb:38 DnsServer module finished
2018-05-25 12:45:15 <1> susetest(20032) [Ruby] clients/dns-server.rb:39 ----------------------------------------

Also available in: Atom PDF