Project

General

Profile

action #36057

[functional][y][fast] No such schema "DejaDup" - error message about gsettings in seemingly unrelated test

Added by okurz about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Bugs in existing tests
Start date:
2018-05-10
Due date:
2018-05-22
% Done:

0%

Estimated time:
Difficulty:
Duration: 9

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-iscsi_ibft@64bit fails in
curl_https

Reproducible

Fails since (at least) Build 288.8

Expected result

Nothing about "gsettings" is called in console tests or error message is ignored/hidden when it does not have an effect.

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz about 2 years ago

  • Status changed from New to Workable

mloviska you and me have this introduced trying to hide the dejadup popup in gnome within the keymap_or_locale test module. It shows up now in another test module. So an easy way would be to call utils::clear_console at the end of the keymap_or_locale module. But maybe also the stderr of the gsettings command should be redirected to /dev/null when we do not care when dejadup is not available. WDYT?

#2 Updated by mloviska about 2 years ago

Sure, that should be done in any case. However I am not really convinced that it will fix this issue. Script /tmp/scriptnw9e_.sh contains only one line 'curl -f -v https://eu.httpbin.org/get 2>&1' and according to the log it looks like the server was not reachable at that time.

[2018-05-09T20:21:49.0056 CEST] [debug] curl -f -v https://eu.httpbin.org/get failed: script timeout at /usr/lib/os-autoinst/testapi.pm line 926.

[2018-05-09T20:21:49.0056 CEST] [debug] Maybe the network is busy. Retry: 7 of 7
[2018-05-09T20:21:49.0056 CEST] [debug] # Test died: curl failed (with retries) at /var/lib/openqa/cache/tests/sle/tests/console/curl_https.pm line 34.

https://eu.httpbin.org is reachable atm, so maybe we can try to just restart this job. Nevertheless I will update keymap_or_locale module.

#3 Updated by mloviska about 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to mloviska

#6 Updated by mloviska about 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF