Project

General

Profile

action #35568

[sle][functional][u] test fails in consoletest_setup - login prompt not ready to type

Added by JERiveraMoya over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 18
Start date:
2018-04-26
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-ppc64le-registered+gnome+dev_tools_all_packages_dvd@ppc64le fails in
consoletest_setup

We might need to create a needle to ensure the prompt is ready when tty is selected, but it requires to consider side effect in other tests.
In this test most of the login typing happens when the prompt is not ready.

Reproducible

Fails since (at least) Build 586.3 (current job)

Expected result

Last good: 581.1 (or more recent)

Suggestions

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #35742: [functional][u] test fails in consoletest_setup - premature user name typingRejected2018-05-02

History

#1 Updated by okurz over 3 years ago

  • Subject changed from [sle][functional] test fails in consoletest_setup - login prompt not ready to type to [sle][functional][u] test fails in consoletest_setup - login prompt not ready to type
  • Due date set to 2018-05-22
  • Target version set to Milestone 16

curious, it is not the problem we have tackled recently with the too generic text-login needle. Do you have an idea how the needle for the "login prompt ready" could look like? Because what I see in the screenshot is a screen that already looks ready. So maybe something else really stalled the system.

Looking into https://openqa.suse.de/tests/1646237/file/consoletest_setup-journal.log I can find some error reports. For example:

Apr 25 22:54:40 linux-9wyg systemd-udevd[386]: Process '/bin/touch /var/lib/lsvpd/run.vpdupdate' failed with exit code 1.
Apr 25 22:54:40 linux-9wyg systemd-udevd[389]: Process '/bin/touch /var/lib/lsvpd/run.vpdupdate' failed with exit code 1.
Apr 25 22:54:40 linux-9wyg systemd-udevd[389]: Process '/bin/touch /var/lib/lsvpd/run.vpdupdate' failed with exit code 1.

repeats a lot and more stuff.

Would you care to report this as a bug please?

#2 Updated by JERiveraMoya over 3 years ago

I was referring to the "underscore" () that appears in other archs, for instance https://openqa.suse.de/tests/1647752#step/consoletest_setup/2 when login, but if it is not blinking I guess the user is writing and keys are lost for a while. It is also visible this "" in the second attempt in ppc: https://openqa.suse.de/tests/1646237#step/consoletest_setup/43. It might worth to try to add it to tty4-selected-20180313 or create a new one. I am not sure previous work about it if it easy or not.
Interesting, it might be stalled for some reason, thanks: Bug created: https://bugzilla.suse.com/show_bug.cgi?id=1091175

#3 Updated by okurz over 3 years ago

  • Description updated (diff)
  • Due date deleted (2018-05-22)
  • Status changed from New to Workable
  • Priority changed from Normal to Low
  • Target version changed from Milestone 16 to Milestone 18

JERiveraMoya wrote:

I was referring to the "underscore" (_) that appears in other archs, for instance https://openqa.suse.de/tests/1647752#step/consoletest_setup/2 when login, but if it is not blinking I guess the user is writing and keys are lost for a while.

Yes, that might actually work but only if the we give the corresponding needle check the no_wait => 1 option, otherwise we would check the screen about once per second and the cursor blinks once per second so most likely we would have lot of false alarms. It's an idea to explore but probably with lower prio unless we see this more often. Let's postpone a bit.

Thank you for the bug report.

#4 Updated by okurz over 3 years ago

  • Related to action #35742: [functional][u] test fails in consoletest_setup - premature user name typing added

#5 Updated by okurz over 3 years ago

  • Description updated (diff)
  • Status changed from Workable to Resolved
  • Assignee set to JERiveraMoya

Ok, I will close this one as "resolved" concerning the bug report. The part of "missing keys while typing login" should be handled in #34339

#6 Updated by okurz over 3 years ago

  • Target version changed from Milestone 18 to Milestone 18

Also available in: Atom PDF