Project

General

Profile

action #35437

action #30649: [tools][openqa] Improve performance by using migrations and external snapshots

action #32968: [kernel][tools] Refactor QEMU backend - Create QEMU process manager and save configuration state

[kernel][tools] QEMU Refactor - Publish disk

Added by rpalethorpe over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2018-04-24
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Write the overlays into a copy of the base block device image and publish it (do_extract_assets).

History

#1 Updated by rpalethorpe over 2 years ago

  • Status changed from New to Workable
  • Assignee set to rpalethorpe
  • Target version set to 448

#2 Updated by rpalethorpe over 2 years ago

  • Status changed from Workable to In Progress

#3 Updated by rpalethorpe over 2 years ago

qemu-img seems to be broken by design in relation to backing file chains and relative paths, but I think I have found a way around it and things are progressing.

#4 Updated by rpalethorpe over 2 years ago

Finally can publish a disk: http://rpws.suse.cz/tests/349#downloads

#5 Updated by rpalethorpe over 2 years ago

  • Status changed from In Progress to Resolved

#6 Updated by sebchlad about 2 years ago

  • Target version changed from 448 to doing board - kernel

#7 Updated by sebchlad about 2 years ago

  • Target version changed from doing board - kernel to Done

Also available in: Atom PDF