Project

General

Profile

Actions

action #35431

closed

action #30649: [tools][openqa] Improve performance by using migrations and external snapshots

action #32968: [kernel][tools] Refactor QEMU backend - Create QEMU process manager and save configuration state

[kernel][tools] QEMU Refactor - Clean up miscellaneous weird stuff

Added by rpalethorpe almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2018-04-24
Due date:
% Done:

0%

Estimated time:

Description

Decide whether to delete apparently unused features and workarounds or reimplement them (e.g. LVM, autoinst.img/FDD, HDDFORMAT).

Actions #1

Updated by rpalethorpe almost 6 years ago

  • Target version set to 448
Actions #2

Updated by rpalethorpe almost 6 years ago

  • Status changed from Workable to In Progress

Delete AUTO_INST variable and floppy disk controller code. Also tried adding proper PFLASH drives: https://github.com/os-autoinst/os-autoinst/pull/754#issuecomment-389546857

Actions #3

Updated by rpalethorpe almost 6 years ago

It appears to work on x86 except that it always tries to boot from the installation media, whereas on the current version it starts booting from the drive after installation. Not sure if this is caused by me setting the pflash code drive as readonly, but including the vars in the code file. I have changed it to use the code file without a vars section so that it hopefully uses the vars to store the new boot order. On the other hand I may just need to set the hd as bootindex=0 and it will fallback to the cd drive to begin with, which might be what it is currently doing and I have reversed the order somehow.

In order to populate the pflash variables with the correct asset file path, I need to change OpenQA to recognize assets starting with PFLASH_ as HDD assets or just rename the variable to start with HDD (i.e. HDD_PFLASH_CODE).

Actions #4

Updated by rpalethorpe almost 6 years ago

it was the vars file

Actions #5

Updated by rpalethorpe almost 6 years ago

Need to rebase the pflash overlays... maybe.

Actions #6

Updated by rpalethorpe almost 6 years ago

Publishing pflash vars images is working on X86: http://rpws.suse.cz/tests/398#downloads (this chains three jobs together).

Actions #7

Updated by rpalethorpe over 5 years ago

Enabled snapshots under virtio VGA and updated code which disables them under NVMe. Remove code disabling them for raw disks, because it is possible to create qcow2 overlays of raw disks and I don't give people the option of creating creating raw overlays although it would probably work as well.

Actions #8

Updated by rpalethorpe over 5 years ago

  • Status changed from In Progress to Resolved
Actions #9

Updated by sebchlad over 5 years ago

  • Target version changed from 448 to 445
Actions #10

Updated by sebchlad over 5 years ago

  • Target version changed from 445 to Done
Actions

Also available in: Atom PDF