Project

General

Profile

action #33958

[sle][functional][u][fast] test fails in zypper_lifecycle - 'end of support' line not found

Added by zluo about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2018-03-28
Due date:
2018-04-10
% Done:

0%

Estimated time:
Difficulty:

Description

okurz mentioned in https://bugzilla.suse.com/show_bug.cgi?id=1057788 with his PR
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4686

And it fixed. Here it might be a different issue:
Test died: Product 'end of support' line not found at /var/lib/openqa/cache/tests/sle/tests/console/zypper_lifecycle.pm line 141

Please investigate.

Observation

openQA test in scenario sle-15-Installer-DVD-aarch64-allpatterns@aarch64 fails in
zypper_lifecycle

Reproducible

Fails since (at least) Build 533.2

Expected result

Last good: 530.1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Project - action #30613: [functional][y][hard] script_output might include extra serial outputResolved2018-01-222018-08-28

History

#1 Updated by okurz about 4 years ago

  • Subject changed from [sle][functional] test fails in zypper_lifecycle - 'end of support' line not found to [sle][functional][u][fast] test fails in zypper_lifecycle - 'end of support' line not found
  • Due date set to 2018-04-10
  • Status changed from New to Workable
  • Assignee set to okurz
  • Priority changed from Normal to High
  • Target version set to Milestone 15

Ok, I should investigate

#2 Updated by okurz about 4 years ago

  • Status changed from Workable to In Progress

Clearly again our known "script_output receives unexpected output" issue #30613. https://openqa.suse.de/tests/1583445/file/serial0.txt is an example serial output on x86_64. The relevant output block is:

bhn_c

Product end of support before 2045-08-17                
Codestream: SUSE Linux Enterprise Server 15             2028-07-30
    SUSE Linux Enterprise Server 15                     n/a*

No packages whose support ends before 2045-08-17.

*) See https://www.suse.com/lifecycle for latest information
SCRIPT_FINISHEDbhn_c-0-

with the special marker "bhn_c" which marks beginning and end.

bhn_c



Welcome to SUSE Linux Enterprise Server 15 RC3 (aarch64) - Kernel 4.12.14-15-default (ttyAMA0).

eth0: 10.0.2.15 fec0::1811:a4ef:ff1d:3fcb


susetest login: 
Product end of support before 2045-08-17                
Codestream: SUSE Linux Enterprise Server 15             2028-07-30
    SUSE Linux Enterprise Server 15                     n/a*

No packages whose support ends before 2045-08-17.

*) See https://www.suse.com/lifecycle for latest information
SCRIPT_FINISHEDbhn_c-0-

is the example from one of the failing aarch64 jobs. As we can see there is a new getty prompt popping up in between of the output block. As we are looking for the line "Product end of support" which looks like it is there but maybe the newline is messed up because of the line "susetest login: […]" the regex match fails. Again we have two options: Try to solve it for good for script_output or adjust the regex in the test which is maybe too restrictive when looking for a beginning of a line with /^Product end of support before/. I think we want to do that nevertheless.

#3 Updated by okurz about 4 years ago

  • Related to action #30613: [functional][y][hard] script_output might include extra serial output added

#4 Updated by riafarov about 4 years ago

Are you actually working on this one? There is no update for the last 6 days...

#5 Updated by okurz about 4 years ago

  • Status changed from In Progress to Resolved

Yeah, sorry, Actually I was and got distracted. I am not sure What I mentioned in the last comment is true though: "Try to solve it for good for script_output or adjust the regex in the test which is maybe too restrictive when looking for a beginning of a line with /Product end of support before/. I think we want to do that nevertheless."

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4777 is a PR to improve the robustness of the product-line match

https://openqa.suse.de/tests/1604048

Also available in: Atom PDF