Project

General

Profile

action #32653

workers stall and no longer grab jobs

Added by coolo over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Concrete Bugs
Target version:
Start date:
2018-03-02
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

I've seen this repeatedly now:

Mar 01 22:36:52 openqaworker2 worker[18833]: [info] cleaning up 01515682-sle-12-SP3-Desktop-DVD-Updates-x86_64-Build20180301-1-qam-regression-message@64bit
Mar 01 22:36:52 openqaworker2 worker[18833]: Mojo::Reactor::Poll: I/O watcher failed: better don't do it twice at /usr/share/openqa/script/../lib/OpenQA/Worker/Jobs.pm line 159.

and then they don't act. But the worker is reported as online:
Alive: yes
Websocket connection: Active
Seen: about a minute ago
Status: Online

But you can see it's not in: last job 11 hours ago.

History

#1 Updated by coolo over 2 years ago

  • Status changed from New to Resolved

This is caused by an old workaround - deployed the fixed version.

#2 Updated by szarate over 2 years ago

  • Target version changed from Ready to Done

Also available in: Atom PDF