Project

General

Profile

action #32401

[QAM] test fails in userspace_systemd

Added by vsvecova over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-02-27
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-Updates-x86_64-mau-qa_userspace_systemd@64bit fails in
userspace_systemd

From serial_terminal.txt:

# /usr/share/qa/qaset/bin/junit_xml_gen.py -n 'regression' -d -o /tmp/junit.xml /var/log/qaset ; echo _dMLG-$?-
[/usr/share/qa/qaset/bin/junit_xml_gen.py]WARNING: No submission info for testsuite systemd
[/usr/share/qa/qaset/bin/junit_xml_gen.py]WARNING: No log dir inside submission log of testsuite systemd
[/usr/share/qa/qaset/bin/junit_xml_gen.py]DEBUG: Parsing testsuite iostat: iostat
Traceback (most recent call last):
  File "/usr/share/qa/qaset/bin/junit_xml_gen.py", line 512, in <module>
    dc.collect_log()
  File "/usr/share/qa/qaset/bin/junit_xml_gen.py", line 426, in collect_log
    shutil.rmtree(ts_dir)
  File "/usr/lib64/python2.7/shutil.py", line 239, in rmtree
    onerror(os.listdir, path, sys.exc_info())
  File "/usr/lib64/python2.7/shutil.py", line 237, in rmtree
    names = os.listdir(path)
OSError: [Errno 20] Not a directory: '/tmp/junit_generator-87372/iostat'
_dMLG-1-
# 

yosun, could you please look into this, since you're the maintainer of this test?
Or else feel free to reassign to someone else. Thank you!

Reproducible

Fails since (at least) Build 20180226-2

Expected result

Last good: 20180226-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by yosun over 4 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 100

The problem is version earlier than sle15 don't has this package apparmor-abstractions

Problem: nothing provides apparmor-abstractions needed by qa_test_systemd-1-39.1.x86_64
Solution 1: do not install qa_test_systemd-1-39.1.x86_64
Solution 2: break qa_test_systemd-1-39.1.x86_64 by ignoring some of its dependencies

#2 Updated by yosun over 4 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF