Project

General

Profile

action #31999

[sle][functional][yast][medium] lvm autoyast profile now tests schrinking, test requires adjustments

Added by riafarov over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2018-02-20
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Observation

We now test shrinking using lvm profile: https://github.com/yast/aytests-tests/commit/7f78ab2116425ed8d6bbe768407d75cdd2260bd9

So shown popup is expected, and we need to adjust test to process it properly. This change doesn't appear for SLE 12, as is not merged there, so only affects aytests package for SLE 15.

openQA test in scenario sle-15-Installer-DVD-x86_64-autoyast_lvm@64bit fails in
installation

Reproducible

Fails since (at least) Build 459.1

Expected result

Last good: https://openqa.suse.de/tests/1477282 (SLE 12)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz over 2 years ago

  • Assignee set to riafarov
  • Target version set to Milestone 16

please make it workable, e.g. expected result.

#2 Updated by riafarov over 2 years ago

  • Subject changed from [sle][functional][yast] lvm auoyast profile now tests schrinking, test requires adjustments to [sle][functional][yast] lvm autoyast profile now tests schrinking, test requires adjustments
  • Description updated (diff)
  • Assignee deleted (riafarov)

#3 Updated by riafarov over 2 years ago

  • Status changed from New to Feedback
  • Assignee set to riafarov

In ay installation we have mechanism to process known warnings. However,
recently we have changed profiles, so not timeout is there and we catch
all messages to track product changes. To keep old functionality when we
would like to test timeouts now one can use AUTOYAST_VERIFY_TIMEOUT
variable.

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4486

#5 Updated by riafarov about 2 years ago

  • Subject changed from [sle][functional][yast] lvm autoyast profile now tests schrinking, test requires adjustments to [sle][functional][yast][medium] lvm autoyast profile now tests schrinking, test requires adjustments
  • Status changed from Feedback to Resolved

Original problem solved, having couple more.

Also available in: Atom PDF