Project

General

Profile

action #31021

test fails in yast2_dns_server - invalid bash syntax [rpduced

Added by dimstar about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-01-29
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_ncurses@64bit fails in
yast2_dns_server

Reproducible

Fails since (at least) Build 20171029

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

The code produces a bash command like:

systemctl is-active named || true) | grep -E "active"
^
This is invalid

Error was introduced with https://github.com/os-autoinst/os-autoinst-distri-opensuse/commit/21fff9096f3445cf46ebaf2fa33ed88dad12fa59#diff-c4dec954f95a88ba0831d832f6d95ef0

History

#2 Updated by okurz about 5 years ago

  • Status changed from New to Resolved
  • Assignee set to dimstar

https://openqa.opensuse.org/tests/597471 shows that at least the original report issue is fixed.

Also available in: Atom PDF