Project

General

Profile

action #30850

[sle][functional]test fails in execute_test_run -> script_output used wrong

Added by okurz over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-01-26
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-process_stress@64bit fails in
execute_test_run

Reproducible

Fails since (at least) Build 414.13 (current job)

Expected result

Last good: 410.1 (or more recent)

Problem

See #30613. If possible work with bash variables within the SUT, e.g. assert_script_run('test_log=$(ls /var/log/qa/ctcs2/); tar cjf /tmp/$test_log.tar.bz2 -C /var/log/qa/ctcs2 $test_log'); but as we need the logfile to upload later I could not find a complete solution now.

Further details

Always latest result in this scenario: latest


Related issues

Is duplicate of openQA Tests - action #29637: [tools][kernel] test suddenly print login words -> script_output used wrongResolved2017-12-20

History

#1 Updated by yosun over 3 years ago

  • Related to action #29637: [tools][kernel] test suddenly print login words -> script_output used wrong added

#2 Updated by yosun over 3 years ago

I think the line "eth0 xxxx" is a minor issue, the point I can't understand is why SUT alway randomly logout and print login information.
https://progress.opensuse.org/issues/29637

#3 Updated by okurz over 3 years ago

  • Related to deleted (action #29637: [tools][kernel] test suddenly print login words -> script_output used wrong)

#4 Updated by okurz over 3 years ago

  • Is duplicate of action #29637: [tools][kernel] test suddenly print login words -> script_output used wrong added

#5 Updated by okurz over 3 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF