Project

General

Profile

action #30826

[functional][opensuse][leap][u][bsc#1080752]test fails in rails - check how to conduct a proper ruby stack testing

Added by lnussel over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2018-01-25
Due date:
2018-06-05
% Done:

0%

Estimated time:
Difficulty:
Duration: 94

Description

Observation

openQA test in scenario opensuse-15.0-DVD-x86_64-extra_tests_in_textmode@64bit fails in
rails

The test tries to compile some native extensions. For that ruby-devel is needed (and gcc and what not). Just install it before. The environment changes all the time so we never know what's needed next.

Reproducible

Fails since (at least) Build 77.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by lnussel over 2 years ago

#3 Updated by okurz over 2 years ago

  • Subject changed from test fails in rails to [functional][opensuse][leap]test fails in rails
  • Due date set to 2018-03-13
  • Target version set to Milestone 14

#4 Updated by zluo over 2 years ago

  • Status changed from New to Workable
  • Assignee set to zluo

take over

#6 Updated by zluo over 2 years ago

  • Status changed from Workable to In Progress

#7 Updated by okurz over 2 years ago

Looks like for now being blocked in https://bugzilla.opensuse.org/show_bug.cgi?id=1080752

#8 Updated by zluo over 2 years ago

zypper install ruby-devel resolves compilation issue on TW, but not for Leap:

http://e13.suse.de/tests/388

There is a problem with nokogiri.

#9 Updated by zluo over 2 years ago

capybara is required which cannot be found to install

#10 Updated by zluo over 2 years ago

  • Status changed from In Progress to Blocked

#11 Updated by okurz about 2 years ago

  • Subject changed from [functional][opensuse][leap]test fails in rails to [functional][opensuse][leap][bsc#1080752]test fails in rails

#12 Updated by okurz about 2 years ago

  • Due date changed from 2018-03-13 to 2018-03-27
  • Target version changed from Milestone 14 to Milestone 15

#13 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-03-27 to 2018-04-10

#14 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-04-10 to 2018-04-24

#15 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-04-24 to 2018-05-08
  • Target version changed from Milestone 15 to Milestone 16

still blocked, moving

#16 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-05-08 to 2018-05-22

bug seems to be still valid - moving over to next Sprint

#17 Updated by mgriessmeier about 2 years ago

Don't know what's the status of the bug, it's still open and not updated for a while, but I couldn't find a test failure on it...
okurz could you please check?

#18 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-05-22 to 2018-06-05

#19 Updated by mgriessmeier about 2 years ago

  • Subject changed from [functional][opensuse][leap][bsc#1080752]test fails in rails to [functional][opensuse][leap][u][bsc#1080752]test fails in rails - check how to conduct a proper ruby stack testing
  • Status changed from Blocked to Workable

#20 Updated by zluo about 2 years ago

  • Status changed from Workable to In Progress

#21 Updated by zluo about 2 years ago

  • Status changed from In Progress to Resolved

set as resolved.

Also available in: Atom PDF