Project

General

Profile

action #30817

sshd fails to enable/disable/configure firewall

Added by dimstar over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-01-25
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-update_Leap_42.3_gnome@64bit fails in
sshd

Reproducible

Fails since (at least) Build 20180123

Expected result

Last good: 20180122 (or more recent)

Further details

Always latest result in this scenario: latest

More info

Recently, the openQA tests were changed to assume firewalld in all scenarios. The assumption is wrong though, as only fresh installations get firewalld; upgrades keep the firewall module they had in use pre-update. This is due to there not being any migration path for the firewall rules (automatic migration might leave the machine in an insecure state)

At the moment at least, all upgrades coming from Leap < 15.0 will maintain SFW2
(this issue appears in the product tests and in staging tests - which is blocking)


Related issues

Is duplicate of openQA Tests - action #28726: [sle][functional][autoyast][sle15][medium]handle all occurences of SuSEfirewall2 for SLE15Resolved2017-12-012018-01-30

History

#1 Updated by dimstar over 4 years ago

besides the sshd test failures, there are other issues related, like fixup/enable_firewall in 13.1->TW upgrades for example

#2 Updated by dimstar over 4 years ago

  • Assignee set to okurz

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4267 is underway (assigning to okurz, who is working on this)

#3 Updated by okurz over 4 years ago

  • Is duplicate of action #28726: [sle][functional][autoyast][sle15][medium]handle all occurences of SuSEfirewall2 for SLE15 added

#4 Updated by okurz over 4 years ago

  • Status changed from New to Rejected

merged, tests retriggered. Closing as duplicate of #28726

Also available in: Atom PDF