Project

General

Profile

action #29909

Upgrade to PHP7

Added by flacco over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Duration:

Description

We have to upgrade the invis-server to php7. The now used Version 5.5. is out of maintenance and newer openSUSE Versions possibly ship only php7.

I think that the most wepapps we have included in invis-server still support php7. Biggest problem could be the invis-portal.

History

#1 Updated by flacco over 2 years ago

First test with switching to php7 results in some missing packages:

Paket 'php7-pear-Auth_SASL' nicht gefunden.
Paket 'php7-pear-MDB2' nicht gefunden.
Paket 'php7-pear-MDB2_Driver_mysqli' nicht gefunden.
Paket 'php7-pear-MIME_Type' nicht gefunden.
Paket 'php7-pear-Mail' nicht gefunden.
Paket 'php7-pear-Mail_Mime' nicht gefunden.
Paket 'php7-pear-Mail_mimeDecode' nicht gefunden.
Paket 'php7-pear-Net_IDNA2' nicht gefunden.
Paket 'php7-pear-Net_LDAP2' nicht gefunden.
Paket 'php7-pear-Net_SMTP' nicht gefunden.
Paket 'php7-pear-Net_Sieve' nicht gefunden.
Paket 'php7-pear-Net_Socket' nicht gefunden.

#2 Updated by flacco over 2 years ago

  • % Done changed from 0 to 20

In a first test invis-portal and cornaz seems to work with php7.

I had to made one correction in /srv/www/htdocs/portal/inc/classes/adLDAPUtils.php line 104++:

old code:

    return preg_replace('/([\x00-\x1F\*\(\)\\\\])/e',
                        '"\\\\\".join("",unpack("H2","$1"))',
                        $str);

new code:

    return preg_replace_callback('/([\x00-\x1F\*\(\)\\\\])/',
                        function($matches) {
                            return '"\\\\\"'.join("",unpack("H2","$matches")); },
                        $str);

I'm absolutely not sure if this is correct.

#3 Updated by flacco over 2 years ago

  • Target version set to 14.0

#4 Updated by flacco about 2 years ago

  • Start date deleted (2018-01-02)

#5 Updated by flacco about 2 years ago

  • Status changed from New to In Progress

#6 Updated by flacco about 2 years ago

  • % Done changed from 20 to 30

Packetnames and pathnames switched from php5 to php7.

#7 Updated by flacco about 2 years ago

Bug in openSUSE: php7 session.safe_path has wrong permissions: http://bugzilla.suse.com/show_bug.cgi?id=1093025

#8 Updated by flacco about 2 years ago

  • % Done changed from 30 to 60

Most things are working with php7.

php-imap is dropped by openSUSE maintainers. We have to fix the corNAz login. It must work without php-imap.

#9 Updated by flacco about 2 years ago

php7 session.safe_path problem is fixed. It was caused by a missing requirement: https://build.opensuse.org/request/show/607440

#10 Updated by flacco about 2 years ago

Bug #1093025 fixed!

#11 Updated by ingogoeppert about 2 years ago

Update is still in review for Factory... But: If apache is installed (or you created the missing user) and you get an update for php7 (with or without the fix) the permissions are correct after the update.

#12 Updated by flacco about 2 years ago

  • % Done changed from 60 to 80

Next Step. invis-Servers Mailaccount-Management Tool CorNAz is now integrated inside the invis-portal. After this we don't need the php-Modul "IMAP" any longer.

#13 Updated by ingogoeppert about 2 years ago

/var/lib/php7 permissions bug fixed in tumbleweed

#14 Updated by flacco almost 2 years ago

  • % Done changed from 80 to 90

Last test is pending.

#15 Updated by flacco almost 2 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 90 to 100

Job done

Also available in: Atom PDF