Project

General

Profile

action #28603

[sle][functional][sle15][easy] "textmode+kvm_server_role" and "textmode+xen_server_role" run for the first time -> adjust needles for SLE15

Added by okurz almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2017-11-30
Due date:
2017-12-19
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-textmode+kvm_server_role@64bit fails in
system_role

Reproducible

Fails since (at least) Build 352.1

Expected result

Last good: SLE 12 SP3 GM "kvm"

Acceptance criteria

  • AC1: Job fails on any non-trivial needle-update, necessary test adjustement or product bugs
  • AC2: After needle changes scenarios are passing or properly labeled with a ticket reference not pointing to this one

Tasks

  • Run the test locally or on production, create the necessary simple needles

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz almost 4 years ago

  • Priority changed from Normal to High

#2 Updated by okurz almost 4 years ago

  • Due date set to 2017-12-19

will inform PO about my planning suggestion

#3 Updated by JERiveraMoya almost 4 years ago

  • Assignee set to JERiveraMoya

Added needle directly in openQA UI and job retriggered: https://openqa.suse.de/tests/1282249
Job now failing in patterns but the root cause is hostname test when running: systemctl reload-or-restart network.service.
br0 becomes empty after this command as displayed in serial logs.

PR to fix hostname test in order to pass pattern test:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3978

Currently is failing patterns test.

#5 Updated by okurz almost 4 years ago

  • Target version set to Milestone 12

#6 Updated by JERiveraMoya almost 4 years ago

PR updated to indicate a soft failure.

#7 Updated by okurz almost 4 years ago

Please focus on closing this progress ticket. We clearly stated in the ACs that we do only the "easy" parts

#8 Updated by JERiveraMoya almost 4 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF