Project

General

Profile

action #28270

[sle][functional][sporadic][easy] test fails in disk_activation - needs needle recreated because we do not have an old one anymore?

Added by okurz about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2017-11-23
Due date:
2017-12-19
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-s390x-ext4@s390x-zVM-vswitch-l2 fails in
disk_activation

Reproducible

Fails since (at least) Build 331.1

Expected result

Last good: 330.1 (or more recent)

AC1: popup https://openqa.suse.de/tests/1265315#step/disk_activation/6 is handled in a proper way
AC2: disk_formatting is working in 20/20 tests

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz almost 4 years ago

  • Due date set to 2017-12-19
  • Target version set to Milestone 12

#2 Updated by mgriessmeier almost 4 years ago

  • Subject changed from [sle][functional]test fails in disk_activation - needs needle recreated because we do not have an old one anymore? to [sle][functional][sporadic][easy] test fails in disk_activation - needs needle recreated because we do not have an old one anymore?
  • Description updated (diff)
  • Status changed from New to In Progress

sporadic issue which happens when DASD is in undefined state,
we had this a long time ago covered in our code, but it seems that the needle got cleaned because it was not happening for a long time

#3 Updated by mgriessmeier almost 4 years ago

  • Status changed from In Progress to Feedback

actions taken:

  • recreated needle
  • triggered job 20 times over night

#4 Updated by mgriessmeier almost 4 years ago

  • Status changed from Feedback to In Progress

okay - this needs more investigation...

#5 Updated by mgriessmeier almost 4 years ago

  • Status changed from In Progress to Resolved

needle for workaround deleted, conducted 30 tests which were all successful and formatted during YaST
the popup in question wasn't shown once, but with the needle adoption it should be handled correct

see verification runs:
http://opeth.suse.de/tests/{6147..6176}

Also available in: Atom PDF