Project

General

Profile

action #27506

[qam] test fails in 1_shim_suite - missing repository on dist

Added by pcervinka almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-11-08
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-Updates-x86_64-Build20171107-1-slenkins-tests-shim-control@64bit fails in
1_shim_suite

Reproducible

Fails since (at least) Build 20171107-1

Expected result

Last good: 20171106-1 (or more recent)

Further details

Always latest result in this scenario: latest

Test tries not existing repo:
http://dist.suse.de/install/SLP/SLE-12-SP3-Server-TEST/x86_64/DVD1/

 Refreshing service 'SUSE_Linux_Enterprise_Server_12_SP3_x86_64'.
 Refreshing service 'SUSE_Linux_Enterprise_Software_Development_Kit_12_SP3_x86_64'.
 Retrieving repository 'SRPMS' metadata [.error]
 Warning: Skipping repository 'SRPMS' because of the above error.
 Repository 'SRPMS' is invalid.
 [SRPMS|http://dist.suse.de/install/SLP/SLE-12-SP3-Server-TEST/x86_64/DVD1/] Valid metadata not found at specified URL
 Please check if the URIs defined for this repository are pointing to a valid repository.
 Some of the repositories have not been refreshed because of an error.
 Reading installed packages...
 Loading repository data...
 Package 'shim' has source package 'shim'.
 Source package 'shim' for package 'shim' not found.
 Resolving package dependencies...

History

#1 Updated by thehejik almost 4 years ago

  • Status changed from New to In Progress
  • Assignee set to thehejik

For SP3 we should definitely use GM repo and not TEST repo. Trying to fix for all SLEnkins tests.

#2 Updated by thehejik almost 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Fixed https://openqa.suse.de/tests/1247432#step/1_shim_suite/2

I just changed TEST repo to GM repo for SLE12 SP3 in shim testsuite.

Also available in: Atom PDF