Project

General

Profile

action #27415

[sle][functional][openqareview] test fails in systemd_testsuite - The testsuite needs improvements from tblume

Added by SLindoMansilla over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
Bugs in existing tests
Start date:
2017-11-06
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

The testsuite needs improvements from tblume

openQA test in scenario sle-15-Installer-DVD-aarch64-suse_patches-systemd_testsuite@aarch64 fails in
systemd_testsuite

Acceptance criteria

  • AC1: The test suite only shows a failure if there is a product bug.
  • AC2: The logs from the test suite are uploaded properly on failure.

Reproducible

Fails since (at least) Build 321.5

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by SLindoMansilla over 4 years ago

  • Description updated (diff)

#3 Updated by tsaupe over 4 years ago

Testmachine for ppc64le: zinfandel-3.arch.suse.de

Installation sources:

3 | SLES15-15-0 | SLES15-15-0 | Ja | (r ) Ja | Ja | ftp://dist.suse.de/install/SLP/SLE-15-Installer-Beta1/ppc64le/DVD1/

1 | Basesystem-Module_15-0 | Basesystem-Module 15-0 | Ja | (r ) Ja | Ja | ftp://dist.suse.de/install/SLP/SLE-15-Module-Basesystem-Beta1/ppc64le/DVD1/

4 | Server-Applications-Module_15-0 | Server-Applications-Module 15-0 | Ja | (r ) Ja | Ja | ftp://dist.suse.de/install/SLP/SLE-15-Module-Server-Applications-Beta1/ppc64le/DVD1/
2 | QA_Head | head development of QA packages (SLE-15) | Ja | (r ) Ja | Nein | http://download.suse.de/ibs/QA:/Head/SLE-15/

Issue is not reproducable in this installation.
Need the detailed log of the failing test for further investigation.

#4 Updated by okurz over 4 years ago

  • Target version set to Milestone 12

#5 Updated by SLindoMansilla over 4 years ago

  • Status changed from New to Feedback

Logs are now provided in the test results. Waiting for feedback from tsaupe.

#6 Updated by tsaupe over 4 years ago

Failing test on aarch64 is test-seccomp:

-->
Assertion 'errno == EFAULT' failed at src/test/test-seccomp.c:248, function test_protect_sysctl(). Aborting.
sysctlseccomp terminated by signal ABRT.
Assertion 'wait_for_terminate_and_warn("sysctlseccomp", pid, true) == EXIT_SUCCESS' failed at src/test/test-seccomp.c:258, function test_protect_sysctl(). Aborting.
<--

I could also reproduce it on a physical aarch64 testmachine (mustang4.arch.suse.de)
Investigating...

#7 Updated by tsaupe over 4 years ago

The udev test failing on ppc64le points to a disk space issue.
udev-test.pl.log shows:

-->
umount: test/tmpfs: no mount point specified.
cp: cannot create symbolic link 'test/tmpfs/sys/class/block/sda9': No space left on device
cp: cannot create symbolic link 'test/tmpfs/sys/class/block/sda7': No space left on device
cp: cannot create symbolic link 'test/tmpfs/sys/class/block/loop6': No space left on device
cp: cannot create symbolic link 'test/tmpfs/sys/class/block/sdb': No space left on device
cp: cannot create symbolic link 'test/tmpfs/sys/class/block/sda1': No space left on device
cp: cannot create symbolic link 'test/tmpfs/sys/class/block/loop2': No space left on device
cp: cannot create symbolic link 'test/tmpfs/sys/class/block/sda8': No space left on device
cp: cannot create symbolic link 'test/tmpfs/sys/class/block/sda5': No space left on device
cp: cannot create symbolic link 'test/tmpfs/sys/class/block/loop4': No space left on device
cp: cannot create symbolic link 'test/tmpfs/sys/class/block/sda6': No space left on device
cp: cannot create symbolic link 'test/tmpfs/sys/class/block/sda': No space left on device
cp: cannot create symbolic link 'test/tmpfs/sys/class/block/md0': No space left on device
cp: cannot create symbolic link 'test/tmpfs/sys/class/block/sdb1': No space left on device
cp: cannot create directory 'test/tmpfs/sys/class/scsi_host': No space left on device
cp: cannot create directory 'test/tmpfs/sys/class/graphics': No space left on device
cp: cannot create directory 'test/tmpfs/sys/class/tty': No space left on device
cp: cannot create directory 'test/tmpfs/sys/class/scsi_device': No space left on device
cp: cannot create directory 'test/tmpfs/sys/block': No space left on device
cp: cannot create directory 'test/tmpfs/sys/devices': No space left on device
unable to copy test/sys at /var/opt/systemd-tests/test/udev-test.pl line 1549.
--<

That would also explain why I couldn't see it on my testmachine.
Could you retry the test with a larger disk image?

#8 Updated by SLindoMansilla over 4 years ago

The directory /var/opt/systemd-tests/test/tmpfs/ is tmpfs, so the amount of RAM is the problem.

I am doing my local tests on a ppc64le machine with 706MB of RAM and 2.0GB of SWAP.

tsaupe, how much RAM and SWAP has the ppc machine where you have done the tests?

#9 Updated by SLindoMansilla over 4 years ago

Test failed with 1024 MB RAM
Test passed with 4096 MB RAM
Test passed with 2048 MB RAM

I have set QEMURAM=2048 for test suite suse_patches-systemd_testsuite

Verification run for ppc succeeded: osd#1255470

#11 Updated by SLindoMansilla over 4 years ago

  • Status changed from Feedback to Resolved

On aarch64, the failure is caused by a bug: https://bugzilla.suse.com/show_bug.cgi?id=1069239

Label of last job updated.

Also available in: Atom PDF