Project

General

Profile

action #27090

ldb library conflict

Added by flacco over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-10-28
Due date:
% Done:

100%

Estimated time:

Description

Since one of the last upgrades of the package ldb to version 1.2.x in our samba AD repos, sssd refuces to start after setup. After installing the original openSUSE 42.3 package ldb in version 1.1.29 everything works.

The problem is that our own samba packages are build against the newer ldb package.

I've no idea how we can fix this. Just installing the older package couldn't be the right way, this may cause other dependency problems.

History

#1 Updated by ingogoeppert over 4 years ago

To fix this, we have to build both packages against the same ldb-library. The same problems can happen with the other libraries we build in the AD-subprojects. We have to include the AD-subproject as package source into the main projects.

#2 Updated by flacco over 4 years ago

OK, I include the samba repos to all our other repos, but for sssd this is not the solution. I've disabled the build of sssd for leap 42.2 and 42.3 to close the gap between our packages (1.16) and the releases (1.13). That means the setup installs sssd from the original repos and they are not built against our libraries.

#3 Updated by ingogoeppert over 4 years ago

If you don't build the sssd against the same libraries, you can not solve the conflict.

#4 Updated by flacco over 4 years ago

That's the problem. ;-(

Is it possible to build this package automatically in this version which is used by ... mist das krieg ich nicht auf englisch hin.

Ist es möglich in unseren Repos automatisch jeweils genau die sssd version zu bauen, die die jeweilige Leap Version verwendet?

Building sssd was necessary for openSUSE 13.1, because it's sssd version didn't support Active-Directory. Since openSUSE ships version bigger than 1.12 everything could be fine and building our own packages is obsolete...

#5 Updated by ingogoeppert over 4 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

Needs to tested: We disabled publishing the ldb library.

#6 Updated by flacco over 4 years ago

  • % Done changed from 50 to 80

looks good, sssd is running after setup.

user mapping works too.

#7 Updated by flacco over 4 years ago

  • % Done changed from 80 to 90

#8 Updated by flacco over 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

It works, but it's not perfect. With the upcoming openSUSE Leap 15 we switch to the openSUSE samba packages, which don't have this problem.

#9 Updated by ingogoeppert over 4 years ago

  • Project changed from invis-server to invisAD-setup
  • Category deleted (Bug)
  • Target version deleted (13.0)

Also available in: Atom PDF