Project

General

Profile

action #26972

[functional][sporadic][medium]user_gui_login/gdm: no mouse, resulting in no mouse-over user selection

Added by dimstar over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2017-10-24
Due date:
2018-01-02
% Done:

0%

Estimated time:
Difficulty:

Description

Every so often, I see user_gui_login tests failing on gdm/gnome

The effect seems to be that there is no mouse cursor visible, which is expected 'in the center of the screen' and which has a 'user highlight' (on mouse over) as a side effect.
As the mouse cursor is missing there, it happens that the user is not being highlighed

Sample test failure: https://openqa.opensuse.org/tests/512222#step/user_gui_login/6
(it happens frequently on the 13.1 update scenario, but not exclusively)


Related issues

Copied from openQA Tests - action #26970: [functional]user_gui_login/sddm: password frequently mistypedResolved2017-10-24

History

#1 Updated by dimstar over 5 years ago

  • Copied from action #26970: [functional]user_gui_login/sddm: password frequently mistyped added

#2 Updated by dimstar about 5 years ago

  • Subject changed from user_gui_login/gdm: no mouse, resuling in no mouse-over user selection to [functional]user_gui_login/gdm: no mouse, resuling in no mouse-over user selection

#3 Updated by okurz about 5 years ago

  • Due date set to 2018-01-02
  • Target version set to Milestone 13

#4 Updated by zluo about 5 years ago

  • Status changed from New to In Progress

#5 Updated by zluo about 5 years ago

  • Status changed from In Progress to Resolved
  • Assignee set to zluo

set as resolved.

#6 Updated by okurz about 5 years ago

  • Subject changed from [functional]user_gui_login/gdm: no mouse, resuling in no mouse-over user selection to [functional][sporadic][medium]user_gui_login/gdm: no mouse, resuling in no mouse-over user selection
  • Status changed from Resolved to In Progress

zluo wrote:

this issue has been fixed.

By what?

The last failure is just 10 job runs ago: https://openqa.opensuse.org/tests/555889#step/user_gui_login/6
If there is a test change please reference the PR. Otherwise I doubt this sporadic issue is fixed

#7 Updated by zluo about 5 years ago

at least the problem doesn't happen

#8 Updated by okurz about 5 years ago

  • Subject changed from [functional][sporadic][medium]user_gui_login/gdm: no mouse, resuling in no mouse-over user selection to [functional][sporadic][medium]user_gui_login/gdm: no mouse, resulting in no mouse-over user selection
  • Due date changed from 2018-01-02 to 2018-01-16
  • Assignee deleted (zluo)

We need better statistics to prove it working or not

#9 Updated by dimstar about 5 years ago

I think with https://github.com/os-autoinst/os-autoinst-distri-opensuse/commit/f9ad136bd506028b9df5fc08ce38bed161d46109 this won't happen anymore - as there is now an explicit click with the mouse on the right user

#10 Updated by okurz about 5 years ago

  • Due date changed from 2018-01-16 to 2018-01-02
  • Status changed from In Progress to Resolved
  • Assignee set to qkzhu

Ok, then let's assume the ticket to be actually resolved

Also available in: Atom PDF