Project

General

Profile

action #26914

[sle][functional][s390x][s390x-kvm] s390x-kvm does never exit from "assert_shutdown" but zkvm works -> investigate how the machines differ, maybe problem on s390p8?

Added by okurz over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Target version:
-
Start date:
2017-09-28
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Clone from #25638: See https://openqa.suse.de/tests/1223349# for an example for a s390x-kvm job failing in assert_shutdown, stuck there until openQA aborts the job after 2h.
Since then we implemented a workaround in https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/lib/utils.pm#L786 for (s390x && !zkvm)

Acceptance criteria

  • AC1 Workaround removed from code
  • AC2 "assert_shutdown" can be called on s390x-kvm and the tests do not incomplete on that call (e.g. no openQA job timeout after 2h)

Steps to reproduce


Related issues

Copied from openQA Tests - action #25638: [sles][functional][s390x] test fails in shutdown: VNC stall detected, needs to be investigatedResolved2017-09-282017-10-25

History

#1 Updated by okurz over 5 years ago

  • Copied from action #25638: [sles][functional][s390x] test fails in shutdown: VNC stall detected, needs to be investigated added

#2 Updated by okurz over 5 years ago

  • Status changed from In Progress to Feedback
  • Assignee set to okurz

could be addressed within #26886 already. Let's see after the corresponding PR is merged and accepted.

#3 Updated by okurz over 5 years ago

  • Status changed from Feedback to Resolved

seemed to have fix it: https://openqa.suse.de/tests/1236004

Also available in: Atom PDF