Project

General

Profile

action #26860

[sles][functional][maintenance] test fails in aplay - Tones are sporadically played with lower frequencies

Added by riafarov about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2017-10-19
Due date:
2017-11-22
% Done:

0%

Estimated time:
Difficulty:

Description

I've accidentally removed ticket #18778 instead of removing my invalid comment.
Content recovered from original ticket:

Observation

openQA test in scenario sle-12-SP2-Server-DVD-Updates-x86_64-mau-extratests@64bit fails in
aplay

Tones are sporadically played with lower frequencies

Reproducible

Fails since (at least) Build 20170424-2
It fails sporadicaly. Seen on aarch64 and x86_64.

Expected result

Last good: 20170424-1 (or more recent)

Further details

Always latest result in this scenario: latest

SLindoMansilla has investigated the issue, and we would like to introduce soft-failure as test is not important for SLE distribution and related bug won't be fixed.

Related bug: https://bugzilla.opensuse.org/show_bug.cgi?id=1048271

History

#1 Updated by riafarov about 4 years ago

  • Description updated (diff)
  • Status changed from New to In Progress

#2 Updated by riafarov about 4 years ago

  • Status changed from In Progress to Feedback

Fix required method to check audio and not assert:
https://github.com/os-autoinst/os-autoinst/pull/873

Changes to the test itself:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3750

#3 Updated by riafarov about 4 years ago

Changes to openQA merged, waiting when they will be deployed to osd and o3 to merge changes to the test.

#4 Updated by okurz about 4 years ago

  • Due date changed from 2017-10-25 to 2017-11-08

carry over to sprint 3 because we should be unblocked again within that sprint after os-autoinst deployment planned after sle15 beta1.

#5 Updated by okurz about 4 years ago

  • Due date changed from 2017-11-08 to 2017-11-22
  • Status changed from Feedback to In Progress
  • Assignee changed from riafarov to okurz
  • Target version changed from Milestone 11 to Milestone 12

deployed on osd, currently blocked by missing deployment on o3. Taking the ticket myself to discuss with szarate, riafarov and sebchlad about that topic.

#6 Updated by okurz about 4 years ago

  • Status changed from In Progress to Resolved

In the end I deployed myself. https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3750 for tests needing the new API are merged. No problems observed. The aforementioned "latest" scenario did not fail since 19 days, verification run: https://openqa.suse.de/tests/1257496#step/aplay/19

Also available in: Atom PDF