Project

General

Profile

action #25988

[sle][functional]test fails in snapper_cleanup - free space is less than 50% of the fs

Added by okurz about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2017-10-11
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-extra_tests_filesystem@64bit fails in
snapper_cleanup

Reproducible

Fails since (at least) Build 299.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by riafarov about 4 years ago

  • Assignee set to riafarov

#2 Updated by riafarov about 4 years ago

  • Status changed from New to In Progress

With these changes we should see a problem more clearly: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3875
Previously we were trying to verify exclusive disk space checking free space. However, we are creating 1GB files on the drive, which is not related to the space occupied by the snapshots.
Additionally we should check exclusive disk space after cleanup.

Another problem we see on x86_64 is following:
https://openqa.suse.de/tests/1244551#step/snapper_cleanup/76 which seems to be a bug, but also occurs sporadically.

#3 Updated by okurz about 4 years ago

  • Target version set to Milestone 12

#4 Updated by riafarov about 4 years ago

  • Subject changed from [sle][functional]test fails in snapper_cleanup - test is hard to debug and needs a new maintainer, volunteers? to [sle][functional]test fails in snapper_cleanup - free sapce is less than 50% of the fs
  • Status changed from In Progress to Feedback

The PR provides better way of testing exclusive disk space allocated for the snapshots. On x86_64 there is sporadic failure with DBus.Error.NoReply. I performed 20 runs locally and wasn't able to reproduce an issue. Attempts to reproduce the issue manually using qcow image form the job and new installation also didn't succeed. Last 2 builds didn't have this problem, keeping an eye on the job.

#5 Updated by riafarov about 4 years ago

  • Subject changed from [sle][functional]test fails in snapper_cleanup - free sapce is less than 50% of the fs to [sle][functional]test fails in snapper_cleanup - free space is less than 50% of the fs

#6 Updated by riafarov about 4 years ago

  • Status changed from Feedback to Resolved

Seems to work well in production, including openSUSE:
https://openqa.suse.de/tests/1251763
https://openqa.opensuse.org/tests/534204

Also available in: Atom PDF