Project

General

Profile

action #25920

[sle][functional]test fails in addon_products_via_SCC_yast2 - unexpected root dialog after x11_start_program rewrite

Added by okurz about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2017-10-11
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-sles+sdk+proxy_SCC_via_YaST@64bit fails in
addon_products_via_SCC_yast2

Reproducible

Fails since (at least) Build 288.8

Expected result

Should look for root-auth-dialog in startup command

Acceptance criteria

  • AC1: Test does something useful for SLE15
  • AC2: Test still works against SLE12

Suggestion

  • This is a yast dialog. lib/y2x11test already has helper methods which most likely should be used here which should make sure we catch the root auth dialog (0.5-2h)
  • After the first step is done review the expected result of the test, compare against SLE12SP3 and do something useful for SLE15 as well (1-6h)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz about 4 years ago

  • Description updated (diff)
  • Status changed from New to In Progress
  • Target version set to Milestone 12

#2 Updated by thehejik about 4 years ago

  • Assignee set to thehejik
  • % Done changed from 0 to 50

#4 Updated by thehejik about 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

#5 Updated by okurz about 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: sles+sdk+proxy_SCC_via_YaST
https://openqa.suse.de/tests/1245784

#6 Updated by okurz about 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: sles+sdk+proxy_SCC_via_YaST
https://openqa.suse.de/tests/1261890

#7 Updated by okurz almost 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: sles+sdk+proxy_SCC_via_YaST
https://openqa.suse.de/tests/1293703

Also available in: Atom PDF