action #25546

openQA does not work very well with blue screen by 64bit-ipmi Backend

Added by xguo over 2 years ago. Updated almost 2 years ago.

Status:RejectedStart date:25/09/2017
Priority:LowDue date:
Assignee:okurz% Done:

0%

Category:Infrastructure
Target version:QA - future
Difficulty:
Duration:

Description

There is blue screen during step to boot_from_pxe to perform openSUSE Leap 42.3 bare metal installation by openQA with 64bit-ipmi Backend.

Thus, it does not catch at the correct needles for openQA.

FYI, it does not reproduce 100% for this issue.

Restart following openQA service as workaround.
systemctl restart openqa-scheduler.service;systemctl status openqa-scheduler.service;sync
systemctl restart openqa-gru.service;systemctl status openqa-gru.service;sync
systemctl restart openqa-websockets.service;systemctl status openqa-websockets.service;sync
systemctl restart openqa-webui.service;systemctl status openqa-webui.service;sync
systemctl restart openqa-worker@1.service;systemctl status openqa-worker@1.service;

boot_from_pxe-sshd-server-started-blusscreen-20170925.png (9.47 KB) xguo, 26/09/2017 09:35 am

3592

History

#1 Updated by okurz over 2 years ago

I doubt this qualifies as a problem for "openQA" itself. Shouldn't it be within the "openQA tests" project? Can you share links to openQA jobs that failed because of this? Otherwise it's very hard to reproduce. You may want to follow https://progress.opensuse.org/projects/openqav3/wiki#defects as a ticket template to describe the problem in a more structured way.

#2 Updated by xguo over 2 years ago

Please refer to the following my openQA link and attachment for getting more details:
http://10.67.131.7/tests/150#step/boot_from_pxe/8

#3 Updated by okurz over 2 years ago

  • Project changed from openQA Project to openQA Tests
  • Category changed from 132 to Infrastructure
  • Status changed from New to In Progress

I'm pretty sure this is a problem in the infrastructure, e.g. the specific host. Is it reproducible every time? Does this also happen for another host? I think you should check with your colleagues administering the machines on your office site.

#4 Updated by xguo over 2 years ago

It does reproduce on Supper Micro host, but does not happen 100% (6 in 10 times).

Also, IMHO, it should be openQA issue without infrastructure issue for the specific host

for Supper Micro.

#5 Updated by okurz about 2 years ago

  • Priority changed from Normal to Low
  • Target version set to future

#6 Updated by okurz almost 2 years ago

xguo, how do you propose to continue here? Is the problem still valid?

#7 Updated by okurz almost 2 years ago

  • Status changed from In Progress to Rejected
  • Assignee set to okurz

no response

#8 Updated by okurz almost 2 years ago

  • Target version changed from future to future

Also available in: Atom PDF