Project

General

Profile

action #20090

[sles][functional] test fails in install_and_reboot - An error occurred during installation

Added by dasantiago over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-06-27
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

The test fails in the installer.

openQA test in scenario sle-12-SP1-Server-DVD-Updates-x86_64-mru-install-minimal-with-addons@64bit fails in
install_and_reboot

An error occurred during installation

Reproducible

Fails since (at least) Build 20170626-4 (current job)

This issue seems to be appearing in irregular intervals. Sometimes a test restart solves it, sometimes it doesn't

Expected result

Last good: 20170626-3 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by dasantiago over 4 years ago

This issue seems to be appearing in irregular intervals. Sometimes a test restart solves it, sometimes it doesn't....

#2 Updated by SLindoMansilla over 4 years ago

  • Subject changed from test fails in install_and_reboot to [sles][functional] test fails in install_and_reboot - An error occurred during installation
  • Description updated (diff)

#3 Updated by riafarov over 4 years ago

  • Assignee set to riafarov

#4 Updated by riafarov over 4 years ago

  • Status changed from New to In Progress

#5 Updated by riafarov over 4 years ago

  • Status changed from In Progress to Feedback

It's definitely not the problem with tests, but product issue:
2017-06-26 10:56:50 (none)(2772) [zypp] ZYppFactory.cc(sigsegvHandler):53 Error: signal 11
2017-06-26 10:56:50 (none)(2772) [zypp] ZYppFactory.cc(sigsegvHandler):53 [hd]: (-3) /usr/lib64/libzypp.so.1519 : zypp::dumpBacktrace(std::ostream&)+0x26 [0x7f8a11899656]
2017-06-26 10:56:50 (none)(2772) [zypp] ZYppFactory.cc(sigsegvHandler):53 [hd]: (-2) /usr/lib64/libzypp.so.1519 : +0x32997e [0x7f8a1185497e]
2017-06-26 10:56:50 (none)(2772) [zypp] ZYppFactory.cc(sigsegvHandler):53 [hd]: (-1) /lib64/libc.so.6 : +0x35200 [0x7f8a2a4d9200]
2017-06-26 10:56:50 (none)(2772) [zypp] ZYppFactory.cc(sigsegvHandler):53 vvvvvvvvvv----------------------------------------

It's may be related to btrfs bugs we have had, as got segmentation fault error. As we still verify that bug is fixed, I'll keep an eye on this job before resolving the issue.

#6 Updated by riafarov over 4 years ago

  • Status changed from Feedback to Resolved

Job looks stable for last 20 days. Seems that issue was resolved indirectly.

Also available in: Atom PDF