Project

General

Profile

action #19932

[qam] test fails in 1_default_autogenerated - RuntimeError: unable to create a valid config object

Added by vsvecova about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
2017-06-20
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP2-Server-DVD-Updates-x86_64-Build20170620-4-slenkins-twopence-krb5-control@64bit fails in
1_default_autogenerated

01_run.sh

# failure:

/tmp/slenkins/testenv.xml:1: parser error : StartTag: invalid element name
</testenv>
^
/tmp/slenkins/testenv.xml:1: parser error : Extra content at the end of the document
</testenv>
^
Traceback (most recent call last):
File "./01_run.sh", line 716, in <module>
main()
File "./01_run.sh", line 704, in main
setup()
File "./01_run.sh", line 30, in setup
config = susetest.Config("krb5")
File "/usr/lib64/python2.7/site-packages/susetest.py", line 96, in Config
raise exceptions.RuntimeError("unable to create a valid config object")
RuntimeError: unable to create a valid config object

Reproducible

Fails since (at least) Build 20170620-3

Expected result

Last good: 20170620-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by vsvecova about 5 years ago

Apologies for the horrible formatting in the description; I forgot to use a code block.
Here's a better-looking version:

# 01_run.sh
 # failure: 

 /tmp/slenkins/testenv.xml:1: parser error : StartTag: invalid element name
 </testenv>
  ^
 /tmp/slenkins/testenv.xml:1: parser error : Extra content at the end of the document
 </testenv>
  ^
 Traceback (most recent call last):
   File "./01_run.sh", line 716, in <module>
     main()
   File "./01_run.sh", line 704, in main
     setup()
   File "./01_run.sh", line 30, in setup
     config = susetest.Config("krb5")
   File "/usr/lib64/python2.7/site-packages/susetest.py", line 96, in Config
     raise exceptions.RuntimeError("unable to create a valid config object")
 RuntimeError: unable to create a valid config object

#2 Updated by thehejik about 5 years ago

  • Status changed from New to In Progress
  • Assignee set to thehejik

#3 Updated by thehejik about 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

We were using outdated working copy of os-autoinst-distri-sle repo on openqa.suse.de. This problem has been fixed about 1 month ago. Now the current working copy is back.

But we hit another issue, see https://progress.opensuse.org/issues/19942

Closing this.

Also available in: Atom PDF