Project

General

Profile

action #19808

[sle][functional][opensuse]separate test for yast2_clone_system

Added by lnussel over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2017-06-13
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

yast2_clone_system is hit by #17436 regularly which breaks tests that need the hard disk image. I suggest to separate generating the hard disk image from creating the autoyast profile. Ie create the image in one test, then boot it and generate autoyast profile in another test.


Related issues

Has duplicate openQA Tests - action #20422: new test: clone_system fails in boot_to_desktopRejected2017-07-12

History

#2 Updated by okurz about 5 years ago

  • Subject changed from separate test for yast2_clone_system to [sle][functional][opensuse]separate test for yast2_clone_system

#3 Updated by Anonymous about 5 years ago

  • Assignee set to Anonymous
  • Target version set to Milestone 10

#4 Updated by Anonymous about 5 years ago

  • Status changed from New to In Progress

#5 Updated by lnussel about 5 years ago

any ETA here? hits us again with current leap build

#6 Updated by Anonymous about 5 years ago

Hi Ludwig, I just assigned this ticket to me, and am planning to start with it this week. However I am still in progress with another ticket, so please be a bit more patient. Thanks.

#7 Updated by Anonymous about 5 years ago

The example testrun failed because of zypper_call "in autoyast2" failed. This bug bsc#17436 is already verified fixed. Is it still necessary to seperate yast2_clone_system?

#8 Updated by lnussel about 5 years ago

yes, please remove it.

#9 Updated by Anonymous about 5 years ago

The current yast2_clone_systemy does no more than "zypper in autoyast2" and "yast2 clone_system", I didn't see anywhere about "generating the hard disk image". If it is contained in "yast2 clone_system", it is impossible to separate it.

What should be removed?

#10 Updated by lnussel about 5 years ago

the problem is that this test is called from the "gnome-image" test. So if cloning fails the image creation fails which breaks all follow up test. The test that calls yast2_clone_system should therefore be separate and by itself based on "gnome-image" rather than be part of it.

See the link in comment#1. The whole "console" block shouldn't be there.

#11 Updated by Anonymous about 5 years ago

OK, so you want the whole "console block" (consoletest_setup, yast2_clone_system, consoletest_finish) dropped from gnome-image scenario?

#12 Updated by Anonymous about 5 years ago

  • Subject changed from [sle][functional][opensuse]separate test for yast2_clone_system to [sle][functional][opensuse]drop yast2_clone_system and console tests from gnome-image scenario

#13 Updated by Anonymous about 5 years ago

PR created.

#14 Updated by lnussel about 5 years ago

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3274

So it's as easy as removing CLONE_SYSTEM=1? Then let's remove that from the job template. Note that we need a second job that generates the autoyast profile instead then. Also, the autoyast_reinstall_gnome template needs to be adjusted.

#15 Updated by Anonymous about 5 years ago

gnome-image is the base for many other test scenarios. I don't think we should simply remove yast2_clone_system and console tests from gnome-image scenario. I'll close my PR.

#16 Updated by Anonymous about 5 years ago

  • Subject changed from [sle][functional][opensuse]drop yast2_clone_system and console tests from gnome-image scenario to [sle][functional][opensuse]separate test for yast2_clone_system
  • Assignee deleted (Anonymous)

#17 Updated by lnussel about 5 years ago

  • Assignee set to okurz

So someone needs to remove

CLONE_SYSTEM=1
PUBLISH_HDD_1=%DISTRI%-%VERSION%-%ARCH%-%BUILD%-gnome@%MACHINE%.qcow2

from gnome-image and create another job that does this instead

#18 Updated by okurz about 5 years ago

  • Description updated (diff)

#19 Updated by okurz about 5 years ago

We don't have many problems with this scenario. We run the same scenario on openSUSE Tumbleweed and SLE. I don't see a strong reason to change the scenarios. Nevertheless I triggered some jobs manually to crosscheck if the test plan would be correct:

$ openqa_clone_job_osd 1054948 CLONE_SYSTEM= _GROUP=0 TEST=create_hdd_gnome
Created job #1057865: sle-12-SP3-Server-DVD-x86_64-Build0472-sles12_gnome_create_hdd@64bit -> https://openqa.suse.de/t1057865
$ openqa_clone_job_osd 1054948 BOOT_HDD_IMAGE=1 PUBLISH_HDD_1= HDD_1=SLES-12-SP3-x86_64-Build0472-gnome.qcow2 CLONE_SYSTEM=1 _GROUP=0 TEST=clone_system START_AFTER_TEST=create_hdd_gnome
Created job #1057868: sle-12-SP3-Server-DVD-x86_64-Build0472-sles12_gnome_create_hdd@64bit -> https://openqa.suse.de/t1057868

The first one creates the HDD, the second one is triggered after that and publishes the cloned profile. The execution of the modules within the same scenario takes about 4 minutes (https://openqa.suse.de/tests/1054948/file/autoinst-log.txt), execution in a standalone job about the same so I'm not concerned about an additional time here though.

Also proposed is to harmonize the scenario names on o3 and osd. I propose to call them create_hdd_… in all cases, e.g. create_hdd_gnome.

Opinions?

#20 Updated by okurz about 5 years ago

As confirmed in today's openQA sync call I am going with create_hdd_…. Renamed all test suites on o3 accordingly (…-image -> create_hdd_…) and added new scenario clone_system triggered in both openSUSE Tumbleweed and openSUSE Leap 42.3 .

Also renamed settings now on osd using dump_templates, local editing with sed and stuff and load_templates with manual crosschecking and deletion of left-over old test suites.

Left to do: Extract the clone_system test suite on osd.

OSD adapted as well.

#21 Updated by okurz about 5 years ago

  • Has duplicate action #20422: new test: clone_system fails in boot_to_desktop added

#22 Updated by okurz about 5 years ago

  • Status changed from In Progress to Resolved

I guess we got this covered.

Also available in: Atom PDF