Project

General

Profile

action #19782

[qam] select_console('root-console') is failing

Added by dasantiago over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-06-13
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

All the tests that contain the following code:

select_console('root-console');

are failing.

Examples of failing tests:
https://openqa.suse.de/tests/997964/modules/install_all_from_repository/steps/1/src
https://openqa.suse.de/tests/997965/modules/conman/steps/1/src
https://openqa.suse.de/tests/997955/modules/piglit/steps/1/src
Those tests are failing on the first step

openQA test in scenario sle-12-SP2-Desktop-DVD-Updates-x86_64-qam-regression-piglit@64bit fails in
piglit

Reproducible

Fails since (at least) Build 20170612-5

Expected result

Last good: 20170612-2 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by pluskalm over 4 years ago

  • Subject changed from select_console('root-console') is failing to [qam] select_console('root-console') is failing

#3 Updated by coolo over 4 years ago

that bug is SP3 and sporadic, no? What we see for SP2 is consistent

#4 Updated by okurz over 4 years ago

It's super consistent on 12SP3 as well, failing probably all autoyast tests using gnome and a critical bug -> https://openqa.suse.de/tests/latest?arch=x86_64&machine=64bit&flavor=Server-DVD&version=12-SP3&distri=sle&test=autoyast_sle12_gnome#previous

#5 Updated by coolo over 4 years ago

  • Status changed from New to Resolved

we found the root cause in SP2: openssl update added a getrandom call that blocks if there is no entropy.

#6 Updated by okurz over 4 years ago

cool. Thanks for the information. So it's not https://bugzilla.suse.com/show_bug.cgi?id=1042554

#7 Updated by dasantiago over 4 years ago

Just to have all the info together.

THis is the issue reported in bugzilla https://bugzilla.suse.com/show_bug.cgi?id=1044175

Also available in: Atom PDF