Project

General

Profile

action #19776

openQA webUI markdown issue- display wrong bug number.

Added by dehai over 5 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
-
Start date:
2017-06-13
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

there have an issue on openQA webUI, if the bug summary has string of "bsc#xxx", it will be display the latest bug number, not the right one.

1.like below info:
bsc#1043970 (Ticket status: RESOLVED (FIXED), prio: P5, assignee: yast2-maintainers@suse.de)
2.paste into o.s.d, show:
bsc#1043760">bsc#1043970 (Ticket status: RESOLVED (FIXED), prio: P5, assignee: yast2-maintainers@suse.de)"

detail info , please refer: https://openqa.suse.de/group_overview/62 , added comment by dehai at "Date: 2017-06-13 - 14:06 Build: 0255 (reference 0254)"

History

#1 Updated by mkittler over 5 years ago

The problem is that openQA tries to put an <a>-element for the bugref in the name inside a title attribute which is messing the HTML of course.

#2 Updated by mkittler over 5 years ago

  • Status changed from New to Feedback

This is actually not easy to fix. I see 2 options:

  1. Fix sub bugref_regex in Utils.pm so bugrefs inside a title specified via Markdown are not detected/replaced. The problem is that we're currently using regex for this which is too limited.
  2. Fix the Text::Markdown module which should not produce wrong HTML - also if a title contains a link.

Both seems like much effort for fixing this relatively unimportant bug.

Note that the particular case where the bugref is at the end could easily be fixed via regex. So this would at least fix this concrete issue: https://github.com/os-autoinst/openQA/pull/1372

#3 Updated by mkittler over 4 years ago

  • Assignee deleted (mkittler)

#4 Updated by okurz over 3 years ago

  • Category set to Concrete Bugs

#5 Updated by okurz over 2 years ago

  • Status changed from Feedback to Resolved
  • Assignee set to mkittler

the specific issue was fixed with https://github.com/os-autoinst/openQA/pull/1372 , we do not have further ideas what else to do. So let's state that mkittler resolved it :)

Also available in: Atom PDF