Project

General

Profile

action #19388

Show bugrefs/labels/comments and filters in /tests route like /tests/overview and #previous

Added by okurz over 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
-
Start date:
2017-05-26
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

User story

As a test reviewer looking for common issues in tests regardless of the products/versions/job groups I would like to see if comments exists and filter for failed jobs to find unreviewed jobs efficiently.

acceptance criteria

  • AC1: /tests route shows comments availability on jobs
  • AC2: filters are available over /tests route as well

tasks

  • TODO

further details

This should be done without duplicating all code. A side-goal should be to harmonize /tests and /tests/overview more.


Related issues

Related to openQA Project - action #16556: Need to display "incomplete" jobs in "Previous results"Resolved2017-02-07

Related to openQA Project - action #16692: [tools]Refactor controller code for server-side data tablesResolved2017-02-10

Related to openQA Project - action #25814: load job page, e.g. test details, only on demandResolved2020-04-07

History

#1 Updated by okurz over 4 years ago

  • Related to action #16556: Need to display "incomplete" jobs in "Previous results" added

#2 Updated by mkittler over 4 years ago

  • Status changed from New to In Progress
  • Assignee set to mkittler

#3 Updated by mkittler over 4 years ago

  • Related to action #16692: [tools]Refactor controller code for server-side data tables added

#4 Updated by mkittler over 4 years ago

Due to performance, the 'All tests' table should be made server-side before:

#5 Updated by mkittler about 4 years ago

  • Status changed from In Progress to Feedback

The commit for this (https://github.com/os-autoinst/openQA/commit/2ad797f60e76177b73a67f664916744e116581c1) has been merged anyways. Let's see whether it works in production.

#6 Updated by okurz about 4 years ago

I think we don't run this yet on production. Also I have a problem with the changes from this PR with my local sqlite database but not on lord.arch. I guess it should be ok for now. Next step: Other icons :-)

#7 Updated by mkittler about 4 years ago

Works on O3 instance (comment icon for 'Build18.49 of opensuse-5.10.90-Krypton-Live.x86_64' is shown).

AC1 only mentions comments, but no bug refs/labels. Showing refs/labels would decrease the performance even further because currently the comments would have to be parsed for this.

So I'll continue with implementing a filter similar to what we already on the test overview page. Let's see how much I can avoid duplicating the code.

#8 Updated by mkittler about 4 years ago

  • Status changed from Feedback to In Progress

#10 Updated by okurz about 4 years ago

  • Related to action #25814: load job page, e.g. test details, only on demand added

#11 Updated by mkittler almost 4 years ago

  • Status changed from In Progress to Resolved

Filter and comment icons are working on osd.

#12 Updated by okurz almost 4 years ago

good work. Can you create a follow-up story about the bugrefs and labels? Using the internal bug database should prevent a significant performance regression.

Also available in: Atom PDF