action #19296

[sle][functional]test fails in yast2_lan_restart

Added by dgutu almost 3 years ago. Updated over 2 years ago.

Status:ResolvedStart date:22/05/2017
Priority:HighDue date:
Assignee:dzedro% Done:

100%

Category:Bugs in existing tests
Target version:-
Difficulty:
Duration:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-x86_64-extra_tests_on_gnome@64bit fails in
yast2_lan_restart

Reproducible

Fails since (at least) Build 0393

Expected result

Last good: 0390 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz almost 3 years ago

  • Subject changed from test fails in yast2_lan_restart to [sle][functional]test fails in yast2_lan_restart

reproduced in sles build 0399 in sle-12-SP3-Server-DVD-ppc64le-Build0399-extra_tests_on_gnome_ppc@ppc64le, that is ppc64le

#2 Updated by okurz over 2 years ago

  • Status changed from New to In Progress
  • Priority changed from Normal to High

fails consistently since some time. Also in scenario "yast2_ui" e.g. https://openqa.suse.de/tests/978013#step/yast2_lan_restart/111

The test asserts the file "journal.log" filled by "journalctl -f -u wickedd" in the background to be non-zero. Previously in the last good it contained the line
"susetest wickedd[1O96]: dynO: Notified neighbours about IP address 10.0.2.15". Now it does not anymore. The output of "ip a" looks like the same so the network device is not totally misconfigured.
I asumme that either the test is executed faster so that the output is not there or there is some changed product behaviour, potentially product bug.

Looking into y2log I find:

2017-06-01 01:10:48 <1> susetest(1066) [Ruby] modules/Progress.rb:344 Progress::New(Saving Network Configuration, 9, ["Write drivers information", "Write device configuration", "Write network configuration", "Write routing configuration", "Write hostname and DNS configuration", "Set up network services", "Write firewall settings", "Activate network services", "Update configuration"])
2017-06-01 01:10:48 <1> susetest(1066) [Ruby] modules/LanItems.rb:238 IsItemConfigured: item=0 configured=true
2017-06-01 01:10:48 <1> susetest(1066) [Ruby] modules/NetworkInterfaces.rb:1563 Deleting file: eth0
2017-06-01 01:10:48 <3> susetest(1066) [agent-ini] IniParser.cc(getTimeStamp):932 Unable to stat '/etc/install.inf': No such file or directory
…
2017-06-01 01:10:53 <2> susetest(1066) [agent-modules] ModulesConf.cc(removeEntry):460 removeEntry: no such directive or module (options,virtio_net)
2017-06-01 01:10:53 <3> susetest(1066) [agent-modules] ModulesConf.cc(getTimeStamp):282 Failed to stat /etc/modprobe.d/50-yast.conf: No such file or directory
2017-06-01 01:10:53 <2> susetest(1066) [agent-modules] ModulesConf.cc(writeFile):545 Error while creating backup file in writeFile (): No such file or directory

I wonder if the errors marked with <3> are really the problem here.

and then further on I see

2017-06-01 01:10:56 <1> susetest(1066) [Ruby] modules/NetworkConfig.rb:164 No changes to NetworkConfig -> nothing to write
2017-06-01 01:10:56 <1> susetest(1066) [Ruby] modules/Routing.rb:306 No changes to routing -> nothing to write
2017-06-01 01:10:56 <1> susetest(1066) [Ruby] modules/DNS.rb:361 No changes to DNS -> nothing to write
…
2017-06-01 01:10:56 <1> susetest(1066) [Ruby] network/susefirewall2.rb:1726 Firewall settings weren't modified, skipping...
2017-06-01 01:10:56 <1> susetest(1066) [Ruby] network/susefirewall2.rb:1743 Firewall enable/disable wasn't modified, skipping...
…
2017-06-01 01:10:56 <1> susetest(1066) [Ruby] network/susefirewall2.rb:1655 Configuration hasn't modified, skipping restarting services
…

so some parts of the config did not change and are therefore not rewritten. Also the firewall is not restarted therefore so is that a problem or expected?

Another thing I realized is that x11/yast2_lan_restart is triggered in both "yast2_ui" as well as "extra_tests_on_gnome" so I will remove it from yast2_ui as it seems to be more about lan restarting and wickedd and not the yast module UI only.

#4 Updated by dzedro over 2 years ago

The message yast2_lan_restart test was detecting reboot was removed, see https://bugzilla.suse.com/show_bug.cgi?id=1042851
I'm working on fix

#5 Updated by dzedro over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF