Project

General

Profile

action #19242

[sle][security][fips] test fails in boot_to_desktop when booting full encrypted LVM (including /boot) with fips=1

Added by qmsu over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Target version:
-
Start date:
2017-05-19
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-x86_64-fips_full_lvm_encrypt@64bit fails in
boot_to_desktop

Reproducible

Fails since (at least) Build 0389 (current job)

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #19618: Grub2 needle is not matched after rebootResolved2017-06-06

History

#1 Updated by qmsu over 4 years ago

For full encrypted LVM partitions, password should be typed twice: before grub and after grub

#2 Updated by qmsu over 4 years ago

  • Category changed from Bugs in existing tests to New test

#3 Updated by qmsu over 4 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

Submitted PR#2938 to fix this issue.

#4 Updated by qmsu over 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

PR merged and verified with test run: https://openqa.suse.de/tests/955185
The failure is due to bsc#1031998 which will be fixed soon.

#5 Updated by okurz over 4 years ago

  • Related to action #19618: Grub2 needle is not matched after reboot added

#6 Updated by okurz over 4 years ago

  • Status changed from Resolved to Feedback

Hi qmsu, I am pretty sure that your last PR caused #19618, therefore reopening. Looking at the last good https://openqa.suse.de/tests/950799/file/autoinst-log.txt and comparing with https://openqa.suse.de/tests/982855/file/autoinst-log.txt I can see now that the password prompt is matched twice but then the grub menue is never properly found. The video link accessible from https://openqa.suse.de/tests/982855#step/reboot_gnome/12 should hopefully provide a better picture. Could you take a look please?

#7 Updated by qmsu over 4 years ago

  • Status changed from Feedback to Resolved

The issue had been fixed by PR#3122:
Remove workaround_type_encrypted_passphrase from reboot_gnome

Verified by openQA test run:
https://openqa.suse.de/tests/1019806

#8 Updated by qmsu about 4 years ago

  • Subject changed from [fips] test fails in boot_to_desktop when booting full encrypted LVM (including /boot) with fips=1 to [sle][security][fips] test fails in boot_to_desktop when booting full encrypted LVM (including /boot) with fips=1

Also available in: Atom PDF