Project

General

Profile

Actions

action #19040

closed

console_reboot frequently fails looking for a grub2 needle, possibly due to a timing issue

Added by AndreasStieger about 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-05-09
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

The console_reboot test frequently fails in openSUSE Maintenance OpenQA.

openQA test in scenario opensuse-42.2-Maintenance-x86_64-qam-GM-gnome+updates@64bit fails in
console_reboot

Message is:
Test died: needle 'grub2' not found at /var/lib/openqa/cache/openqa1-opensuse/tests/opensuse/lib/opensusebasetest.pm line 350.

This often passes upon a subsequent run. Could this be made more robust?

Reproducible

Fails since (at least) Build :493653.MozillaFirefox.6663 (current job)

Expected result

Last good: :493608.samba.6732 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues 1 (0 open1 closed)

Related to openQA Tests - coordination #18964: [functional][epic][u]Bootloader/boot functions refactorResolvedokurz2017-10-182018-07-31

Actions
Actions #1

Updated by okurz about 7 years ago

AndreasStieger wrote:

This often passes upon a subsequent run. Could this be made more robust?

If we simply want to accept the longer time it takes for rebooting then we just increase the timeout. If you want to call it a bug and report it we can track it with assert_screen_with_soft_timeout

Actions #3

Updated by Anonymous about 7 years ago

I still meet this problem frequently.

Actions #4

Updated by Anonymous about 7 years ago

  • Assignee set to Anonymous
Actions #5

Updated by Anonymous about 7 years ago

  • Status changed from New to In Progress
Actions #6

Updated by Anonymous about 7 years ago

  • Assignee changed from Anonymous to okurz
Actions #7

Updated by okurz almost 7 years ago

  • Related to coordination #18964: [functional][epic][u]Bootloader/boot functions refactor added
Actions #8

Updated by okurz almost 7 years ago

  • Status changed from In Progress to Resolved

Situation improved by reworking the needles tags and unregistering, e.g. https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2867 and https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2895

Looking at the most recent example in the originally mentioned example https://openqa.opensuse.org/tests/410187 and back for e.g. 100 jobs the latest failing example is https://openqa.opensuse.org/tests/404934#step/console_reboot/3 failing to find any needle, probably because of changed test code. https://openqa.opensuse.org/tests/410187#step/console_reboot/3 is how it should look like. I assume we are done here in general. Please reopen with specific failing cases when you find any. General refactoring of the boot process will be followed on in #18964

Actions #9

Updated by okurz almost 7 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: om_scc_sles12sp2_wsm_allpatterns_full_update_by_zypper_ppc
https://openqa.suse.de/tests/948863

Actions

Also available in: Atom PDF