Project

General

Profile

action #18996

test fails in setup_zdup (all zdup tests apparently)

Added by dimstar over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-05-05
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-zdup-13.1-gnome@64bit fails in
setup_zdup

Reproducible

Fails since (at least) Build 20170505

Expected result

Last good: 20170504 (or more recent)

Further details

Always latest result in this scenario: latest

More observations

Since today, all zdup tests seem to fail switching to the console. I also restarted a Leap 42.3 test that worked yesterday: today it fails the same way as every TW zdup test (https://openqa.opensuse.org/tests/399229). As this is booting an old disk image even before any 'product' specific code to be tested is running, this must be a change on the openQA infra causing this.


Related issues

Related to openQA Tests - coordination #18964: [functional][epic][u]Bootloader/boot functions refactorResolved2017-10-182018-07-31

History

#1 Updated by okurz over 5 years ago

  • Related to coordination #18964: [functional][epic][u]Bootloader/boot functions refactor added

#2 Updated by okurz over 5 years ago

  • Status changed from New to In Progress
  • Assignee set to okurz

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2774#discussion_r114492238 caused the problem for openSUSE because for openSUSE we commonly have auto-login so that assert_screen 'displaymanager' does not apply here.

#3 Updated by okurz over 5 years ago

  • Status changed from In Progress to Feedback

See https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2849 as a "quick-fix" and https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2850 as a proper way by simply reverting the "wait_boot" call in setup_zdup.

#4 Updated by okurz over 5 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF