Project

General

Profile

action #18172

[sle][migration][ha]test fails in zypper_lr consistently

Added by dgutu over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-03-30
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-HA-x86_64-migration_zdup_offline_sle12sp1_ha+allpatterns_fullupdate@64bit fails in
zypper_lr

Reproducible

Fails since (at least) Build 0107@0300 (current job)

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Blocks openQA Tests - action #10996: [sles][migration] fully patch before upgrading (offline+online)Resolved2016-02-29

History

#1 Updated by dgutu over 4 years ago

The tests were missing ADDONS, SCC_ADDONS, SCC_REGCODE_$ADDON variables.
I've added them to the testmodules settings, need to wait until next build.

#2 Updated by dgutu over 4 years ago

https://openqa.suse.de/tests/844402 - this one had a wrong reg key. Already fixed in testmodule settings.

#3 Updated by okurz over 4 years ago

  • Subject changed from test fails in zypper_lr to [sle][migration][ha]test fails in zypper_lr consistently

latest https://openqa.suse.de/tests/846656 still fails, please take a look

#5 Updated by mitiao over 4 years ago

dgutu, like I guessed yesterday, the issue only happens on zdup migration with addons because of using multi isos as repos.
And I re-checked those scenarios and found a redundant setting of addon in them.

My opinion is not to modify the codes to meet less benefit dvd repo which were validated by zypper addrepo/ref in zdup.pm, also avoid to break other existing tests.

So I simply deleted the redundant setting and let's see the result in next build (after 0328)

#6 Updated by mitiao over 4 years ago

I'd say it needs a minor change in the code, please see the PR:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2748

#7 Updated by RBrownSUSE over 4 years ago

  • Blocks action #10996: [sles][migration] fully patch before upgrading (offline+online) added

#8 Updated by RBrownSUSE over 4 years ago

  • Priority changed from Normal to Urgent

Because it blocks #10996

#9 Updated by mitiao over 4 years ago

  • Status changed from New to In Progress
  • Assignee changed from dgutu to mitiao
  • % Done changed from 0 to 100

PR merged and checking results with the latest build on o.s.d.

#10 Updated by mitiao over 4 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF