Project

General

Profile

action #17956

[sles][functional] test fails in command_not_found

Added by nicksinger over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-03-24
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-ppc64le-extra_test_in_textmode_ppc@ppc64le fails in
command_not_found

Reproducible

Fails since (at least) Build 0294 (current job)

Expected result

Last good: 0290 (or more recent)

Further details

I guess this test fails because of the kernel messages printed in between so the cursor moved down and since the needle is so small, it cannot match anymore without the cursor.
This is not a exactly a bug but more of an info that such issues can arise because the kernel decides to print in between.
Is it suitable to adjust the needle to just check for the "$"?
Or is changing the test not an option and we wait until https://bugzilla.suse.com/show_bug.cgi?id=1007813 is fixed?

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #19398: [functional][y] Handle console messages covering ncurses dialogs (was: Remove "console=tty" boot option for installed system)Rejected2017-05-26

History

#1 Updated by riafarov over 4 years ago

  • Related to action #19398: [functional][y] Handle console messages covering ncurses dialogs (was: Remove "console=tty" boot option for installed system) added

#2 Updated by riafarov over 4 years ago

Problem with kernel messages is under discussion and is a common issue for all console tests. The general statement is to issue a bug every time some unwanted kernel message is printed. Resolve this issue and continue with newer one: https://progress.opensuse.org/issues/19398

#3 Updated by riafarov over 4 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF