Project

General

Profile

action #17772

type_string uses wrong text; repeats string from the previous step

Added by vsvecova about 5 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Feature requests
Target version:
-
Start date:
2017-03-17
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Wrong string is used in test. Seems like a previous string is cached and used again in the next step of the test instead of the correct one.

Context:

Test sends Super key to open launcher, then types "settings" to open gnome settings, then is supposed to type something else
(for example "tweak" to open Tweak tool or "users" to open the Users menu), but instead types "settings" once again.

This behavior observed in:

application_starts_on_login
https://openqa.suse.de/tests/816031#step/application_starts_on_login/5

change_password
https://openqa.suse.de/tests/816031#step/change_password/5

login_test
https://openqa.suse.de/tests/816031#step/login_test/5

Same behavior observed a couple of times, occurrence seems rather flaky.
In the below example, occurred five times in a row within 24 hours, then started passing again.
https://openqa.suse.de/tests/818818#previous


Observation

openQA test in scenario sle-12-SP2-Desktop-DVD-Updates-x86_64-qam-regression-gnome@64bit fails in
application_starts_on_login

Reproducible

Fails since (at least) Build 20170315-4

Expected result

Last good: 20170315-3 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by coolo almost 5 years ago

  • Status changed from New to Rejected

only seen then

Also available in: Atom PDF